1. garys11#IM's Avatar
    Hello All,
    I just got a first generation G2 iPhone running OS 3.0, jailbroken/unlocked, and I
    was wondering what is the best version of iTunes should I use (if it makes a
    difference)? Sorry if this is a stupid newbie question, just want to be safe then sorry. I read that the current version of iTunes is not good to use with a jailbroken iPhone...
    06-30-2009 09:11 AM
  2. Tramain's Avatar
    You can use the current version I used the current version the other day with my jailbroken iPhone. I restored it but it worked.
    06-30-2009 09:14 AM
  3. BenGillam's Avatar
    you can only use a 3.0 iphone with itunes 8.2 and higher

    i suspect you read that you shouldnt put 8.2 on (which would subsequently ask to install 3.0 on your iphone) because the jailbreak wasnt ready at the time, whereas it is now
    06-30-2009 10:12 AM
  4. hotrod#AC's Avatar
    Yep. funy is right. Only iTunes 8.2 and higher with iPhone 3.0
    06-30-2009 10:14 AM
  5. garys11#IM's Avatar
    Thank you very much everybody and thank you for quick replies...This site is great!
    06-30-2009 10:19 AM
  6. Bucksfan1's Avatar
    Just use themost current one
    07-02-2009 02:02 PM
LINK TO POST COPIED TO CLIPBOARD