1. gkr747's Avatar
    Hi,

    My unlocked iphone has 2.1 and it is not working with itunes 8 or 7.7

    Error with 8.0:
    "SIM card appears to be not supported"

    Error with 7.7 & 7.5:
    "iphone cannot be used because it requires atleast itunes 8.0 or later"

    So I am basically stuck with no way to use itunes. Please help me!!

    Thank you so much in advance
    Last edited by gkr747; 10-23-2008 at 11:52 AM.
    10-23-2008 11:45 AM
  2. Jeremy's Avatar
    Update everything via iTunes, re-jailbreak/unlock again.
    10-23-2008 12:44 PM
  3. gkr747's Avatar
    btw mine is iphone 3G with version 2.1...pls let me know if still that is what I need to do?
    10-23-2008 12:59 PM
  4. Jeremy's Avatar
    You can not unlock a 3g iPhone with software at the moment. Impossible. You can only jailbreak. Which is not the same thing.
    10-23-2008 02:25 PM
  5. trafeng's Avatar
    I tried two hardware sim unlocks neither of which worked. Finally, I got a gevey-3g sim card which unlocked my iphone 3g version 2.1 Everything appears to work very well. The instructions which came with the sim unlocker said "make sure that you turn off your iphone before inserting GEVEY-3G sim. And also do not use airplane mode in any time." Not using airplane mode is a small price to pay for an unlocked iphone! BTW, I unlocked to the T-Mobile network. Gevey sim purchased through eBay.
    10-24-2008 11:23 AM
LINK TO POST COPIED TO CLIPBOARD