1. angelavs's Avatar
    I have an older iTouch, I'm not sure which however, it was the one they came out with just before making the ones with cameras.

    Anyway, I'm trying to download certain games and I keep getting an error message saying "Update Required, this app requires iOS 4.3". I'm pretty sure my updates are current.

    Is there a way to make these games run? Find this update? or should I just break down and get a newer one?

    Thanks for any advice or suggestions.
    07-28-2012 11:30 AM
  2. pkcable's Avatar
    Sounds like you have a 3rd Gen, that's the last one without the camera. Well actually the 4th Gen is the only 1 WITH a camera, and is the current generation. You should be able to update your ipod touch to the latest 5.1.1 firmware via itunes.
    07-31-2012 11:50 AM
  3. Hassan Bardin's Avatar
    Ios4.3 me permite pas d'installer des applications sur mon iphone
    02-17-2013 03:07 PM
LINK TO POST COPIED TO CLIPBOARD