M1 MacBook Pro deal at Amazon: Save $199 instantly!

  1. Spaz888's Avatar
    I'm having ongoing issues with Wi-Fi calling.

    Randomly (but more often then not) when our iPhones (iPhone XR, XS, 7) using older and latest iOS versions go into stand-by mode Wi-Fi calling is disconnected even though you are still connected to your AP. It makes no difference which AP is used.

    The Wi-Fi antenna icon is still active but the "Wi-Fi Calling" text is missing and then comes back after about 10 seconds (sometimes less) when the iPhone is "awake". VOIP Services such as WhatsApp or Facetime work fine when in standby mode.

    Sometimes (often actually) when an SMS or short code is sent to me (received) while I am using Wi-Fi calling, it won't show up until I disable Wi-Fi calling or Airplane mode when I connect using my direct cellular connection. Even when celluar connectivity is active, Wi-Fi calling overides it and calls are sent directly to voicemail or SMS are queued until the next time you disconnect Wi-Fi calling.
    04-04-2021 05:06 PM
  2. TwitchyPuppy's Avatar
    I really couldn’t say, I’ve never experienced that issue with Wi-Fi Calling. Try resetting network settings, though. It might help! (You’ll need to re-enter your Wi-Fi password, though).
    04-04-2021 09:51 PM
  3. Ledsteplin's Avatar
    Sounds like you have a cell signal that's borderline too good for wifi calling and bad enough for wifi calling. So, wifi calling goes in and out some.
    Last edited by Ledsteplin; 04-04-2021 at 11:03 PM.
    04-04-2021 10:52 PM
  4. Spaz888's Avatar
    I really couldn’t say, I’ve never experienced that issue with Wi-Fi Calling. Try resetting network settings, though. It might help! (You’ll need to re-enter your Wi-Fi password, though).
    It's on different iphones, different wifi access points. Resetting network settings is what everyone says to do but rarely does it do anything.
    04-05-2021 06:19 PM
  5. Spaz888's Avatar
    Sounds like you have a cell signal that's borderline too good for wifi calling and bad enough for wifi calling. So, wifi calling goes in and out some.
    Devices are using airplane mode so celluar is off.
    Ledsteplin likes this.
    04-05-2021 06:20 PM
  6. Ed7789's Avatar
    Have a look at your firewall settings. Wi-Fi Calling uses a protocol called IKEv2 (like IPSec).

    Have also a look at this Apple document which lists all ports Apple software use. Search for “Wi-Fi Calling”.

    https://support.apple.com/en-us/HT202944
    04-05-2021 07:07 PM
  7. Spaz888's Avatar
    Have a look at your firewall settings. Wi-Fi Calling uses a protocol called IKEv2 (like IPSec).

    Have also a look at this Apple document which lists all ports Apple software use. Search for “Wi-Fi Calling”.

    https://support.apple.com/en-us/HT202944
    Wi-Fi calling works with exceptions. It doesn't ALWAYS work in standby mode. It does about 20% of the time.

    Thanks for the link to the ports the iPhone uses! The ports the iPhone uses are UDP 500 and 4500. I have no idea how to verify if either of them are blocked or if they randomly get blocked.

    I don't recall having this issue with iOS 12.
    04-06-2021 02:12 AM
  8. Ledsteplin's Avatar
    Wi-Fi calling works with exceptions. It doesn't ALWAYS work in standby mode. It does about 20% of the time.

    Thanks for the link to the ports the iPhone uses! The ports the iPhone uses are UDP 500 and 4500. I have no idea how to verify if either of them are blocked or if they randomly get blocked.

    I don't recall having this issue with iOS 12.
    You might check with your carrier. They might know more about wifi calling, airplane mode, etc.
    04-06-2021 09:37 AM
  9. Ed7789's Avatar
    Wi-Fi calling works with exceptions. It doesn't ALWAYS work in standby mode. It does about 20% of the time.

    Thanks for the link to the ports the iPhone uses! The ports the iPhone uses are UDP 500 and 4500. I have no idea how to verify if either of them are blocked or if they randomly get blocked.

    I don't recall having this issue with iOS 12.
    While I can’t help you with specifics, I would check that one of these settings are enabled (Different names on the same feature):
    - IPSec Passthrough
    - IKE Passthrough
    - IPSec Application Level Gateway (ALG)
    - IKE ALG

    What these do (simplified) is rewrite the contents of an IPSec datagram with the public IPv4 address and then send it, instead of just sending it as is. They are usually enabled on consumer equipment, and disabled on prosumer and entreprise equipment

    Another thing that might be happening is that the connection does not have enough traffic and it is timing out. That’s something I cannot help with.
    04-06-2021 01:20 PM
  10. Tartarus's Avatar
    I have it enabled but don’t pay any attention to it.
    04-07-2021 10:42 AM
  11. bakron1's Avatar
    I used WiFi calling when I was traveling overseas years ago when cell phone and data service overseas was very expensive.

    But, with most providers offering unlimited calls and data in North America and Mexico on most plans and the overseas data rates are very cheap these days, I don’t see the need to use WiFi calling anymore.
    04-18-2021 04:31 PM

Similar Threads

  1. Replies: 9
    Last Post: Yesterday, 02:25 PM
  2. Replies: 8
    Last Post: 04-09-2021, 07:03 PM
  3. Stun monsters using the powerful Hammer in Monster Hunter Rise
    By iMore.com in forum iMore.com News Discussion & Contests
    Replies: 0
    Last Post: 04-02-2021, 08:12 AM
  4. Apple is now rejecting apps that use third-party SDKs to collect user data
    By iMore.com in forum iMore.com News Discussion & Contests
    Replies: 0
    Last Post: 04-01-2021, 08:30 PM
  5. Apple will reportedly use Tesla's batteries at its California solar farm
    By iMore.com in forum iMore.com News Discussion & Contests
    Replies: 0
    Last Post: 04-01-2021, 04:30 AM
LINK TO POST COPIED TO CLIPBOARD