1. peetpan's Avatar
    Every night my iPhone sets itself in ‘Do Not Disturb’ mode. I always hated this feature because of the possibility of me missing an emergency call from a relative or something of that matter. I know you can turn that off on ‘Settings’, and obviously, I did. But, this iPhone Xs Max doesn’t seem to care about it and sets itself in ‘Do Not Disturb’ avery night. I hate this.
    10-03-2018 11:33 PM
  2. Tartarus's Avatar
    Every night my iPhone sets itself in ‘Do Not Disturb’ mode. I always hated this feature because of the possibility of me missing an emergency call from a relative or something of that matter. I know you can turn that off on ‘Settings’, and obviously, I did. But, this iPhone Xs Max doesn’t seem to care about it and sets itself in ‘Do Not Disturb’ avery night. I hate this.
    In Settings > Do Not Disturb, you can allow all calls to come through while DnD is enabled.
    10-03-2018 11:39 PM
  3. strikeIII's Avatar
    Every night my iPhone sets itself in ‘Do Not Disturb’ mode. I always hated this feature because of the possibility of me missing an emergency call from a relative or something of that matter. I know you can turn that off on ‘Settings’, and obviously, I did. But, this iPhone Xs Max doesn’t seem to care about it and sets itself in ‘Do Not Disturb’ avery night. I hate this.
    Is the schedule disabled? That's probably what's turning it back on.
    10-04-2018 02:32 AM
  4. bamf-hacker's Avatar
    You can also go to individual contacts and turn on emergency bypass for texts and/or calls.

    I have my wife and kids set up with emergency bypass for texts, so even if I am in dnd they come through.
    10-04-2018 04:16 AM
  5. peetpan's Avatar
    I appreciate yall’s responses, but these are just bypasses, which is letting me have what I want, without really fixing it. I would really like for the phone to stop setting itself in DND. Ever.
    10-04-2018 09:12 AM
  6. peetpan's Avatar
    Thank you!
    10-04-2018 09:13 AM
  7. Tartarus's Avatar
    I appreciate yall’s responses, but these are just bypasses, which is letting me have what I want, without really fixing it. I would really like for the phone to stop setting itself in DND. Ever.
    Disable ‘Scheduled’ in DnD Settings.
    10-04-2018 09:46 AM
  8. wenrob's Avatar
    You can also go to individual contacts and turn on emergency bypass for texts and/or calls.

    I have my wife and kids set up with emergency bypass for texts, so even if I am in dnd they come through.
    It seems this feature is gone? There is no more DND in contacts just “Hide Alerts.” I see no way to bypass for individual people anymore.

    Edit: Never mind found it. Who would have thought to look under ringtone of all places?
    https://www.imore.com/how-receive-me...t-disturb-mode
    Tartarus likes this.
    10-04-2018 09:47 AM
  9. wenrob's Avatar
    I appreciate yall’s responses, but these are just bypasses, which is letting me have what I want, without really fixing it. I would really like for the phone to stop setting itself in DND. Ever.
    Do you have scheduled DND turned on?
    10-04-2018 09:48 AM
  10. peetpan's Avatar
    I have DND turned off, like... in general!iPhone Xs Max Do Not Disturb Automation-dnd.jpg
    I believe you should mess with the schedule AFTER you enable DND. Why would I tweak the schedule if DND is off.
    My whole issue is that even DND being OFF, it turns itself ON at night.
    10-04-2018 09:58 AM
  11. bamf-hacker's Avatar
    OH... just turn off scheduled DND in the DND settings and it won't turn on automatically anymore.
    10-04-2018 10:01 AM
  12. bamf-hacker's Avatar
    I have DND turned off, like... in general!Click image for larger version. 

Name:	dnd.jpg 
Views:	2 
Size:	232.4 KB 
ID:	124485
    I believe you should mess with the schedule AFTER you enable DND. Why would I tweak the schedule if DND is off.
    My whole issue is that even DND being OFF, it turns itself ON at night.
    Go to the Clock App and then bedtime and turn off DND there. If it is still coming on you have bedtime mode enabled and that turns on DND.
    10-04-2018 10:02 AM
  13. wenrob's Avatar
    I have DND turned off, like... in general!Click image for larger version. 

Name:	dnd.jpg 
Views:	2 
Size:	232.4 KB 
ID:	124485
    I believe you should mess with the schedule AFTER you enable DND. Why would I tweak the schedule if DND is off.
    My whole issue is that even DND being OFF, it turns itself ON at night.
    I was asking if it was accidentally turned on. You don’t need DND switched to on for the schedule to kick in. It’s automatic which is why I asked. Just trying to help you find the problem.

    I would check “Bedtime” as a PP suggested.
    Also, try turning schedule on and see if Bedtime is checked under there. If it is, switch it off then switch “scheduled” back off.
    peetpan likes this.
    10-04-2018 10:58 AM
  14. peetpan's Avatar
    Man, yes. I found it! I never paid attention to the Options button on the top left.
    iPhone Xs Max Do Not Disturb Automation-dnd-1.jpg iPhone Xs Max Do Not Disturb Automation-dnd2.jpg
    Thanks for the intel!
    wenrob likes this.
    10-04-2018 11:32 AM

Similar Threads

  1. How can I fix problems after updating my IPhone 6 to IOS 12?
    By EnviroTech in forum Ask a Question
    Replies: 5
    Last Post: 10-09-2018, 10:59 PM
  2. How to see after hours stock prices on Stocks APP for iPhone?
    By iMore Question in forum Ask a Question
    Replies: 2
    Last Post: 10-03-2018, 05:45 PM
  3. SMS between iPhone and Android
    By StaticFX in forum Ask a Question
    Replies: 13
    Last Post: 10-03-2018, 02:31 PM
  4. Siri suggestion for calendar not working
    By samduffy in forum Ask a Question
    Replies: 2
    Last Post: 10-03-2018, 12:54 PM
  5. iOS 12 Beta 2 on XS MAX.
    By iMore Question in forum Ask a Question
    Replies: 3
    Last Post: 10-03-2018, 12:53 PM
LINK TO POST COPIED TO CLIPBOARD