1. NSpooner's Avatar
    I’ve had my X since launch and it’s been great. But now the last few weeks I’m noticing a lot of problems when not on WiFi. It will show that I have great signal but I’m getting no LTE or 3g service. I try toggling the radio on and off, rebooting the phone, resetting the network settings, etc. nothing seems to work. I’m on the road all the time for work so I stream podcasts and pandora constantly so it’s becoming a big problem. I searched and didn’t really see anything about this.
    03-13-2019 08:35 AM
  2. pkcable's Avatar
    Could it be a carrier issue? Maybe they are having a bad day or a bad couple days? Anyone else you know on the same carrier, that you can check with?
    03-13-2019 08:55 AM
  3. Spencerdl's Avatar
    I don't have an X, but something similar happened to my 6 Plus or 6s Plus (one of those devices), and I called my carrier and was informed that my device wasn't logged into their systems. They corrected the problem immediately and I never had another problem. I suggest giving your carrier a call.
    Annie_M and pkcable like this.
    03-13-2019 08:55 AM
  4. Lee_Bo's Avatar
    Have you called your carrier and asked if they are having issues?
    Annie_M likes this.
    03-13-2019 08:57 AM
  5. NSpooner's Avatar
    I have two other phones on my plan and they don’t have issues, one is an X and the other is an 8. And I should have clarified it’s not that it never works, it seems to fade in and out. Good tip about calling my carrier, maybe it’s on their end.
    Annie_M and pkcable like this.
    03-13-2019 08:58 AM
  6. doogald's Avatar
    I'd also visit a carrier store to get a replacement SIM card, if the problem persists. It should not cost anything (except the few minutes it takes them to replace the SIM and register it on your account.)
    Annie_M and pkcable like this.
    03-13-2019 09:19 AM

Similar Threads

  1. Domain/IP Issue
    By facecard in forum App Store
    Replies: 2
    Last Post: 03-09-2019, 11:30 AM
  2. Pairing Issue With Car Stereo...
    By darita in forum iPhone XS
    Replies: 4
    Last Post: 02-23-2019, 05:29 PM
  3. iPhone XS Verizon Service Issues
    By PrincessB in forum iPhone
    Replies: 7
    Last Post: 02-19-2019, 08:19 PM
  4. Weird issue with Screentime
    By nikkisharif in forum iOS
    Replies: 5
    Last Post: 02-12-2019, 07:52 PM
  5. Issue with reinstall OS in iMac
    By 4bontz in forum Ask a Question
    Replies: 2
    Last Post: 02-11-2019, 03:58 PM
LINK TO POST COPIED TO CLIPBOARD