1. flyinion's Avatar
    Not sure if this is a bug with 11.2 which I just updated to yesterday evening (missed the announcement apparently) or some incompatibility with my 5 year old Jeep Wrangler's iPhone/iPod input or a new intended behavior or what. I went to play music on the way to work today, usually do it through the USB input in my vehicle. Then I can access playlists via the radio, set them on random, and switch tracks with steering wheel controls.

    Not today. It will start playing on it's own and even go to a new track after one is done, but as soon as I try to use the vehicle controls to skip to a new track it would stop playing and eventually the radio would get an error message. Figured I just needed a reboot so I did that. Then on the way back from lunch, same thing. Sitting in the parking lot I figured out what's going on. If I try to skip a track, once it "hangs" if I pick up the phone and let FaceID unlock it, the music starts playing again on the correct track.

    Uh, what? Is this really the intended behavior?
    12-04-2017 03:50 PM
  2. Quis89's Avatar
    I use bluetooth in my car but I'll test this out via USB this evening and see what happens. This doesn't sound normal though.
    12-04-2017 03:52 PM
  3. flyinion's Avatar
    I use bluetooth in my car but I'll test this out via USB this evening and see what happens. This doesn't sound normal though.
    Thanks, I forgot to mention bluetooth still works fine. I prefer USB though so I can select playlist/etc. from the radio. I tried with and without the Music app loaded.
    12-04-2017 03:57 PM
  4. anon(10000748)'s Avatar
    I’ve been using my usb just fine but I have a ford so it’s through sync.
    12-04-2017 04:57 PM
  5. Just_Me_D's Avatar
    Not sure if this is a bug with 11.2 which I just updated to yesterday evening (missed the announcement apparently) or some incompatibility with my 5 year old Jeep Wrangler's iPhone/iPod input or a new intended behavior or what. I went to play music on the way to work today, usually do it through the USB input in my vehicle. Then I can access playlists via the radio, set them on random, and switch tracks with steering wheel controls.

    Not today. It will start playing on it's own and even go to a new track after one is done, but as soon as I try to use the vehicle controls to skip to a new track it would stop playing and eventually the radio would get an error message. Figured I just needed a reboot so I did that. Then on the way back from lunch, same thing. Sitting in the parking lot I figured out what's going on. If I try to skip a track, once it "hangs" if I pick up the phone and let FaceID unlock it, the music starts playing again on the correct track.

    Uh, what? Is this really the intended behavior?
    That is not normal behavior - at least not in my experience. You should unpair the device from your car and then turn off the power to the car. Afterwards, turn the car back on and then pair your device with it.
    12-04-2017 05:34 PM
  6. flyinion's Avatar
    That is not normal behavior - at least not in my experience. You should unpair the device from your car and then turn off the power to the car. Afterwards, turn the car back on and then pair your device with it.
    How would bluetooth pairing affect the USB "iPod" input though?
    12-04-2017 06:04 PM
  7. flyinion's Avatar
    Ok this just got really weird. I'll test it in my wife's car in a few minutes (different make/model and 3 years newer) but I figured out on the way home (after doing a re-pairing as suggested) that it's not actually a security (FaceID/etc.) issue. I think it might be just a flat out 11.2 bug. So with the phone sitting upside down in my cupholder (USB cable connected) I found if I push the power button to wake the screen up, but NOT unlocked, I can skip tracks as much as I want. As soon as the screen shuts off again, nope.
    12-04-2017 08:27 PM
  8. flyinion's Avatar
    Ok the weirdness is getting really frustrating now lol. It worked just fine in my wife's 2015 Altima. So if it is an iOS bug it's some problem between it and my Jeep's software. I'm now leaning towards the Jeep but will try a new lightning cable tomorrow just in case that's the problem. No idea if Jeep will have any updates for their module but probably not. Time to go buy a new vehicle lol.
    12-04-2017 08:51 PM
  9. flyinion's Avatar
    Sooooo, I have an update on this. Either one of the recent 11.3.x minor updates fixed it (I stopped testing after 11.3 or the first 11.3.x update not sure when exactly) but I just noticed today that for sure on the current 11.4 release I can now skip songs again without the screen having to be on. I can only assume this was some obscure bug that was fixed. Just a reminder, the problem as I found in the end is that my 2012 Wrangler with the factory UConnect/BT module (not the touchscreen just the base radio+Sirius) would not skip tracks while playing music through the iPod/USB interface unless the screen was turned on. It didn't have to be unlocked, just on. Like I could skip a track with the screen off and the music would just stop. As soon as I pushed the power button to wake the screen the next track would start playing.
    06-07-2018 03:52 PM
  10. doogald's Avatar
    Weird bug. I'm glad that they fixed it, though.
    06-07-2018 07:03 PM
  11. flyinion's Avatar
    Weird bug. I'm glad that they fixed it, though.
    Yeah it was a seriously weird bug and it started with 11.2. The phone initially worked fine so it wasn't like it was an iPhone X specific incompatibility or something.
    06-07-2018 07:40 PM

Similar Threads

  1. iPhone 6 texting bug
    By cpedrich in forum iPhone 6
    Replies: 2
    Last Post: 12-06-2017, 03:39 PM
  2. iPhone X setup : OTA or iTunes ?
    By lpiphone in forum iPhone X
    Replies: 4
    Last Post: 12-05-2017, 02:11 PM
  3. Bugs: It's Not Your Phone
    By metllicamilitia in forum iPhone X
    Replies: 19
    Last Post: 12-04-2017, 12:38 PM
  4. Replies: 0
    Last Post: 12-03-2017, 07:34 AM
LINK TO POST COPIED TO CLIPBOARD