1. Miss Daredevil's Avatar
    As the title says, my WiFi keeps disconnecting whenever my phone goes into sleep mode. This started happening the moment I signed with a new internet provider and they came over to set up the new gear. I have read online that turning off WiFi in sleep mode is a feature that is supposed to preserve battery and that the iphone is supposed to be doint that, but I used a number of different WiFi's since getting the phone (my old one from another provider, my friends', public, etc.) and WiFi would ALWAYS stay on even if my phone is in sleep mode and locked for whatever time.

    I suspect the problem is with my new router and my phone (all other phones - Android, Windows, work FINE on my new router and they never disconnect, the WiFi works flawlessly with them). It's just my iPhone that's the problem.

    Can you guys help me?
    07-30-2016 05:00 PM
  2. Ledsteplin's Avatar
    How is the iPhone the problem? Seems to be the new Internet provider. Apparently, that's how they want it to work. I've never heard of a router or modem that works that way. The iPhone is not designed to shut wifi off while asleep.
    07-30-2016 05:16 PM
  3. Miss Daredevil's Avatar
    I'm not saying it is, I'm saying there's a disconnect between the new router and my iPhone. The problem is that this problem only happens to my iPhone, all other phones are fine.
    primacom likes this.
    07-30-2016 05:21 PM
  4. Ledsteplin's Avatar
    I'm not saying it is, I'm saying there's a disconnect between the new router and my iPhone. The problem is that this problem only happens to my iPhone, all other phones are fine.
    It could be the iPhone only uses wifi when it needs to while asleep. That's probably normal. But it shouldn't stay disconnected the entire time.
    07-30-2016 05:25 PM
  5. Miss Daredevil's Avatar
    Could be, but that never happened before.
    07-30-2016 05:27 PM
  6. kch50428's Avatar
    Could be, but that never happened before.
    It likely has happened before... You're just noticing it because of a display lag... iPhones have always had wifi go into a "hot standby" mode when locked to extend battery life.
    07-31-2016 07:05 AM
  7. Miss Daredevil's Avatar
    But why don't my push notifications come through now? Whereas with my old provider I got notifications constantly, even if I hadn't used the phone for a while aka it went into sleep mode.
    07-31-2016 08:25 AM
  8. StayClassy101's Avatar
    If I was you, I would reset my network settings and see if that helps first. Usually when the iPhone processes connections it can save long term ones and process newly attached connections as temporary assignments. This can be the case with some computers, it's possible the same is happening with your iPhone if all your other devices are fine.

    Note: after a network settings reset, all saved connections and wifi passwords would have to be reestablished.
    libra89 and Sherry_B like this.
    07-31-2016 08:30 AM
  9. Miss Daredevil's Avatar
    I will try that, thanks for the advice!
    07-31-2016 08:31 AM
  10. btwoody's Avatar
    I will try that, thanks for the advice!
    So I have had the same issue. For me it only happens with certain networks and I haven't found anything that fixes it. For me it happens when I'm connected to a public hotspot or guest wifi type of networks. When I'm at work I have to connect to their guest network. So my phone constantly disconnects from wifi after I lock the screen, since auto join is on, when I unlock the screen it joins after a few seconds. This has to be the most annoying "feature" I can think of. I understand it saves battery but battery isn't as important as saving data. And to anyone who says the iPhone will connect to wifi when it needs to transfer data even while asleep, is incorrect.
    There isn't anything to do except get used to it. Sorry it happens on ur home network....that would be infuriating.
    12-07-2016 03:38 AM
  11. gaboon13's Avatar
    I will try that, thanks for the advice!
    Turn Auto-login on. Problem solved!
    libra89 likes this.
    12-07-2016 05:10 AM
  12. gaboon13's Avatar
    I will try that, thanks for the advice!
    Also keep background app refresh on for whatsapp.
    12-07-2016 05:19 AM
  13. btwoody's Avatar
    Turn Auto-login on. Problem solved!
    That doesn't help with background data being transferred. Sure if I pick up my phone and unlock it, data will be over wifi, but data transferred while locked is still over cellular.
    12-07-2016 08:45 AM
  14. Ralph Morgotch's Avatar
    I don't have the sleep mode problem that I noticed but I just went through the same problem because I got a brand-new 5G modem router Wi-Fi installed two days ago, and my Wi-Fi kept cutting out.

    It turned out the reason was because when the guy was here setting up the new router, he used all the same network passwords and login code that I had before. This confused the new 5G modem and it kept looking for both Wi-Fi names when you're trying to find the wifi network to connect to. So I had to phone sasktel and it took about 35 minutes for them to wipe the other one out and then do some rebooting and I also had to reconnect to the 5G Wi-Fi name for my router. There were actually two to connect to that were for my router but I had to make sure I choose the one that said 5G, otherwise the names of the networks looked identical.


    So I guess the point is I'm wondering if your new Wi-Fi router is still set to the same login password code you had before and that might be confusing it they might have to reconfigure it for you as a brand-new one, which they should do anyway.

    Edit: now I see how old this thread is and I realize it was probably solved a long time ago
    12-17-2016 04:22 PM
  15. metalchick719's Avatar
    Hmm... I'm having this exact same problem on my SE that I just got last week. It's pretty annoying. Never have this issue on my 6s at all.
    02-24-2017 02:23 PM
  16. b1709946's Avatar
    Turn wifi on (doesn’t matter if you connect to a wifi network now or later, but the wifi toggle must be on). If your ios device supports mobile data, turn it off for now.
    Turn off the device (by keeping the sleep button pressed and then swiping)
    Wait 30s
    Turn it on
    After the home screen loads, reset it (hold the home and sleep buttons down and keep holding until you see the apple logo)
    That’s it.
    05-23-2017 06:46 PM

Similar Threads

  1. Phone is shut off or restarts, apps disappear
    By splyle65 in forum iPhone 6 Plus
    Replies: 3
    Last Post: 08-04-2016, 05:20 PM
  2. Replies: 1
    Last Post: 08-03-2016, 06:15 PM
  3. Why can't I add a playlist to my iPhone?
    By pindorica in forum Ask a Question
    Replies: 10
    Last Post: 08-03-2016, 04:42 AM
  4. My iphones home button is really hot and wont turn on.
    By iMore Question in forum Ask a Question
    Replies: 2
    Last Post: 07-30-2016, 02:09 PM
  5. How do I get s a HomeKit off my phone
    By iMore Question in forum Ask a Question
    Replies: 0
    Last Post: 07-30-2016, 01:54 PM
LINK TO POST COPIED TO CLIPBOARD