1. iPerry7's Avatar
    Hi guys, I have an iphone 5s. Until yesterday , the twitter app on my phone was working fine. But today it couldn't update the timeline when I pulled to refresh. So I deleted the account. But when I tried to sign in again, it won't sign in. When I sign in from the settings it says that the password or Id is incorrect. When I sign in the app itself , the app says could not be authenticated request timed out. What could be the trouble? I have tried powering the phone off and back on several times but to no avail. I can sign in when I open twitter in safari. Please help
    12-17-2013 03:18 AM
  2. joe_fresh's Avatar
    Sounds like twitter is having issues. I would just wait it out.
    12-17-2013 06:49 AM

Similar Threads

  1. Notes taking app with handwriting recognition
    By Bill McNeal in forum iPhone Apps & Games
    Replies: 8
    Last Post: 10-28-2014, 04:12 PM
  2. Funniest iPhone Apps? Cheezeburger/FaceShip lol
    By NewtonGravity in forum iPhone Apps & Games
    Replies: 8
    Last Post: 01-06-2014, 03:30 PM
  3. A cool app of Package for Pages
    By contactus in forum App Store
    Replies: 1
    Last Post: 12-17-2013, 01:01 AM
  4. Replies: 0
    Last Post: 12-16-2013, 04:10 PM