1. liketides's Avatar
    I've got a 4S running 5.1.1. I jailbroke with absinthe 2.0, and everything has been going fine until today. I went into my settings app to turn off vibrate, and when I went to go iinto "Sounds" to do so, I clicked Sounds and the settings app crashed. I haven't downloaded many apps from cydia lately, so I don't think that's the problem. I have been downloading more ringtones with unlimtones, could that be it? I think it was working before I downloaded a whole slew of ringtones last night but I've deleted some and that still hasn't helped.
    I've looked everywhere and googled how to fix this crash problem but I've had no luck, and I'm trying to avoid a restore. I also downloaded Crash Reporter from Cydia and even that did not give me the reason for the problem. Not sure what else to do, anyone have any ideas or should I just restore?
    I think Sounds is the only tab that makes my settings crash when I try to open it.
    08-14-2012 11:10 AM
  2. idrewpage's Avatar
    well, it sounds to me like a system file is corrupted. You will need to restore to fix it. This is a good time to restore anyways, since iOS 6 will be out soon, and you'll be able to get it on release day.
    08-14-2012 11:20 AM
  3. 3cit's Avatar
    In order for crash reporter to work you need syslog as well. Do you have that? Also you can try and disable your Cydia tweaks.
    If it is only the sounds settings under settings, then start by disabling the sound tweaks... You probably only need to delete a tweak.
    08-14-2012 11:25 AM
  4. BLiNK's Avatar
    well, it sounds to me like a system file is corrupted. You will need to restore to fix it. This is a good time to restore anyways, since iOS 6 will be out soon, and you'll be able to get it on release day.
    worst advice/suggestion i have seen all day
    redbeard likes this.
    08-14-2012 11:30 AM
  5. 3cit's Avatar
    <panicked voice>
    WHERE ISTHE JAILBREAK SECTION??!??!?</panicked voice>
    08-14-2012 11:36 AM
  6. liketides's Avatar
    In order for crash reporter to work you need syslog as well. Do you have that? Also you can try and disable your Cydia tweaks.
    If it is only the sounds settings under settings, then start by disabling the sound tweaks... You probably only need to delete a tweak.
    Yes, I have syslog installed, however it doesn't seem to be helping. But I will look around and delete any sounds tweaks I find and see if that helps, thank you.
    08-14-2012 11:41 AM
  7. 3cit's Avatar
    Yes, I have syslog installed, however it doesn't seem to be helping. But I will look around and delete any sounds tweaks I find and see if that helps, thank you.
    You don't have to just randomly delete stuff...
    Do you have sbsettings? If so you can disable tweaks one at a time to isolated the problem... You can also respring into safe mode as a first step to see that it is in fact a tweak causing the settings crash.
    08-14-2012 11:47 AM
  8. liketides's Avatar
    You don't have to just randomly delete stuff...
    Do you have sbsettings? If so you can disable tweaks one at a time to isolated the problem... You can also respring into safe mode as a first step to see that it is in fact a tweak causing the settings crash.
    Well I deleted the app I thought was the problem, Unlimtones, but it didnt help. I also disabled a handful of tweaks that might have also caused the problem but the settings app still crashes every time I try to go to Sounds. However, I can access Sounds in safe mode.
    08-14-2012 11:59 AM
  9. 3cit's Avatar
    Well, go backwards then and turn off EVERY TWEAK, then turn them on one at a time. Or two or three... Isolate the issue first... See when the crash starts to happen...
    This method is WAY BETTER than a restore, even though it's a pain in the bit... Also sometime a respring isn't enough... Have you rebooted after removing tweaks?
    08-14-2012 12:02 PM
  10. liketides's Avatar
    Well, go backwards then and turn off EVERY TWEAK, then turn them on one at a time. Or two or three... Isolate the issue first... See when the crash starts to happen...
    This method is WAY BETTER than a restore, even though it's a pain in the bit... Also sometime a respring isn't enough... Have you rebooted after removing tweaks?
    Okay, I worked backwards like you suggested, and I found the problem. It looks like Springtomize 2 has something to do with it, that's the only thing that made it crash when I turned everything else on and tested it. Also, I did reboot after removing tweaks.
    I really don't want to uninstall springtomize though.. I use it a lot to theme my phone and all that, and I don't understand how that is causing the crash in the first place. I guess I'll mess around with the settings and see if I can fix it, thank you for all your previous suggestions
    08-14-2012 12:29 PM
  11. 3cit's Avatar
    Soringtomize 2 has pretty in depth settings... I've had it since the beginning and still find things within it!
    Maybe one of the "time capsule" events has gone awry or who knows...
    Hope it all gets sorted for you
    08-14-2012 12:45 PM
LINK TO POST COPIED TO CLIPBOARD