1. citibori's Avatar
    I went to download the iMovie app and it tells me that my firmware is incompatible. I am on 4.2.1 and it tells me that I have to be on 4.2.6 which is the Verizon one. Can anyone shed some light on this?
    04-15-2011 04:31 PM
  2. Alli's Avatar
    Simple - if you're a gsm user, update to 4.3.x which is the latest gsm firmware, or update to 4.2.6 if you're with VZW, or don't use iMovie.
    04-15-2011 04:38 PM
LINK TO POST COPIED TO CLIPBOARD