1. graysonip's Avatar
    When I receive a text message that was sent to my Google Voice phone number, that text is likewise delivered to the Messages app on the iPhone. So, my Google Voice texts are double delivered. Is anyone aware of how to stop this? FYI, I've already tried logging into the Google Voice account online, and going to settings for Voicemail and Text. However, I don't see any setting that would prevent double delivery of the Google Voice texts.

    Apppreciate the help. Thanks! :o
    11-16-2010 10:48 PM
  2. graysonip's Avatar
    Ah, figured it out. It's necessary to log into Google Voice online, go to Settings, then Phones (not Voicemail & Texts), choose the iPhone mobile number, click Edit, then uncheck the box for "Receive text messages on this phone". Problem solved. No more duplicate text message delivery.
    11-16-2010 11:04 PM
LINK TO POST COPIED TO CLIPBOARD