1. lurchaddams's Avatar
    I found a post on the Apple Forums...someone suggested a hard reset...

    I reset my phone (hold both buttons down until the phone goes off), and hooked it to my Pioneer head unit, and it works now. Seems strange...but I'll take it.

    ...as it relates to the Pioneer & Kenwood units not recognizing the device after the iOS4 upgrade....
    I can CONFIRM that this works!

    My exact steps to resolve issue
    1. Press the LOCK and HOLD buttons until the phone turns off
    2. Select the appropriate input on the car audio reciever
    3. Connect the USB cable to the unit and phone
    4. Wait for the phone to power on COMPLETELY
    5. Open the iPod controls on the phone (or select song through the unit). Press Play
    6. Enjoy!!!!


    I am way beyond happy about this working! Thanks to evansc22!
    06-22-2010 11:26 AM
  2. John T's Avatar
    Tons of my apps keep crashing when opened
    The Telegraph App does this too. Obviously not optimised for the new OS
    06-22-2010 11:26 AM
  3. jponte55's Avatar
    'DFU mode' ?? Please explain!
    I found this solution for the no data after 4.0 update on 3GS and it worked for me. Option two below was the right choice for me due to not having to do full restore. Hopefully Apple releases an actual fix but everything seeems to be working properly with this configuration. Not sure if its been mentioned in this thread

    "I got this problem on my 3GS, no 3g after upgrading to version 4.0 GM. I found only two solutions.

    1. start a new configuration
    2. go to the web site www,unlockit,co,nz Unlockit - APN Changer for your iPhone on your iphone and follow the instructions.

    For now, I used option 2, maybe apple will issue a fix. In my opinion, there is probably a file permission error on the carrier ipcc file."

    btw, I had to use commas for the url due to this being my first post. Obviously change those to periods and you should be good to go.
    Last edited by jponte55; 06-22-2010 at 11:34 AM.
    06-22-2010 11:31 AM
  4. Enzo#IM's Avatar
    my update went fine. My apps are good. My home screen bookmarks to web pages is jacked up. Even after deleting them and recreating em they will not open safari. My iphone 3g is slower, my inbox freezes and crashes. IOS 4 did nothing for My iphone 3G and seams like a waist since I see no benefit from updating to 4 vs. 3.2 or whatever. This IOS is the same that comes with iPhone 4 I believe it's lacking. Also if the ios 4 for iPad does not fix my wifi issue's im going to be pissed. $600 iPad that I cant use for what I actually bought it for. I really like apple products but WTF fix this stuff It's minor and easy to do.
    06-22-2010 11:37 AM
  5. pdc1's Avatar
    iTouch 32GB 3rd gen 3.1.2 (no JB) -> 4.0

    Didn't go so well, but ultimately successful. Fortunately the upgrade skipped the slow backup step since it already had one from syncing. At first the upgrade seemed to go okay, but got an error before it really started. Then the unit was stuck in DFU mode (more like FU mode I think ). Kept getting 1604 errors. Found a neat solution: when iTunes says it is connecting, but nothing is happening on the device, open task manager and kill iTunes. Then restart iTunes and it connects and restores just fine.

    After the restore, I did not have music or video, but then I had iTunes set to manually manage. A little more manual than I thought I have around a zillion apps (too many free app of the minute sites out there) so it took a long time to resync, but once I got past the 1604 error everything went smoothly.

    Wifi works just fine after the restore, I didn't even have to re-enter any passwords. I haven't noticed any problems with apps, but I haven't done much with the device so far.

    Like: Folders! Though gosh those mini icons are small! Fingers crossed for retina display on iTouch 4th gen this September

    Dislike: Home screen backgrounds. Give me an option for solid colors! There's way too many visual styles with all the icons to add to the visual noise with backgrounds. You'd think Apple would get this.

    Not sure: Multitasking. I don't want every app I run cluttering up my running apps bar. Yeah, you can remove them, but it's a pain if you are running a lot of random apps.
    06-22-2010 11:57 AM
  6. justyntime's Avatar
    Along with the loss of data, MMS, and visual voicemail, and the fuzzy pics...

    I also noticed that my iPhone claims to have 0 songs on it. Playlists are still there and if I fire one up all my songs play...

    I also have a pioneer head unit which works fine but the volume is very noticably lower...

    I cant try any restores until I get home from work... Just wanted to add the 0 songs and lower volume bugs seeing as I didnt see anynoe else report that yet.
    06-22-2010 12:07 PM
  7. jsc315's Avatar
    I seem to have more of a stable wifi connection since I did a Factory Restore now.
    06-22-2010 12:11 PM
  8. Unchewable's Avatar
    ATTENTION if you had a jailbroken iphone using spirit on 3.1.3 with 3gs like me and upgrade to 4.0 without clean install it will break all 3g communication voicemail etc. after clean install i have seen a dramatic improvement.
    06-22-2010 12:14 PM
  9. RSF's Avatar
    Greetings pdc1 and other iTouch users,

    I too have an iTouch 32GB 3rd gen 3.1.3 (no JB). Still didn't "do the jump" to 4.0, though!

    How long did took your upgrade? Been seing on this forum a LOT of iPhone users with a lot of apps and data and songs and photos... and that seems to be part of the problem on the LONGGGGing of the upgrade, was not

    Does anyone did do an upgrade on a iTouch with a few apps an nothing else, did that went OK, or still had probs? Kind of a clean, fresh new, upgrade...
    06-22-2010 12:16 PM
  10. Unchewable's Avatar
    also occasionally the back button on messages disappears so that if i text someone want to back out to text someone else it isn't there
    06-22-2010 12:18 PM
  11. evansc22's Avatar
    I can CONFIRM that this works!

    My exact steps to resolve issue
    1. Press the LOCK and HOLD buttons until the phone turns off
    2. Select the appropriate input on the car audio reciever
    3. Connect the USB cable to the unit and phone
    4. Wait for the phone to power on COMPLETELY
    5. Open the iPod controls on the phone (or select song through the unit). Press Play
    6. Enjoy!!!!


    I am way beyond happy about this working! Thanks to evansc22!
    I've very glad it worked too! I would hate to have to downgrade just to keep this functionality, or worse, buy a new head unit....Thank goodness for the Internets!!
    06-22-2010 12:21 PM
  12. vapor03's Avatar
    Resetting my phone (holding both buttons to power off) corrected the issue with my Sony not being "compatible". Thanks for everyones input.

    I have no other bugs thus far that I have noticed.
    06-22-2010 12:27 PM
  13. MaKin's Avatar
    Resetting my phone (holding both buttons to power off) corrected the issue with my Sony not being "compatible". Thanks for everyones input.

    I have no other bugs thus far that I have noticed.
    Unfortunately for me, this did not help with the isimple. Is this happening to anyone elses/does anyone have a way to correct this?
    06-22-2010 12:30 PM
  14. Ipheuria's Avatar
    I didn't have time to read through the 11 pages or whatever. So everything works sweet except now I seem to have the spontaneous power off problem that was in 3.x I never had it then but I upgraded yesterday to 4 and this morning I pull my phone out of my pocket after it had charged all night and was showing 95% earlier in the morning and the phone was off. In the 2 years I have owned it my phone has never been turned off accidentally in my pocket so this couldn't be a coincidence. I powered it on and I'm going to see if it happens again.

    LOL can I call the fact that 3G doesn't have custom wallpapers a bug?
    06-22-2010 12:40 PM
  15. anon(153966)'s Avatar
    Photos were blurry. iPhone wouldn't be seen by Windows (to thus see it as a hard drive). It would sync, and then on the device, there would be no photos. Albeit, it shows there are 2103 photos on the device...

    Anyway, this evening, I'm going to restore as New, and then re-select the items & apps that I want synced.
    06-22-2010 12:43 PM
  16. Rock48nj's Avatar
    Before I saw this I started another thread on calendar colors being messed up, but figured out a way to fix this. Also I noticed my Find My iPhone was not working but a simple turning off and then back on of the feature solved that problem as well.
    06-22-2010 12:50 PM
  17. LanceWebb's Avatar
    MS Exchange Mail not working. "Cannot Get Mail The connection to the server failed."

    When I go to "Settings", "Mail, Contacts, Calendars", the "Exchange Mail Account" it crashes trying to open and kicks me back to the Home Screen.

    Also noticed going into "Settings" and "General" it crashes the same way, but this happen about every other time.
    06-22-2010 12:53 PM
  18. xxjokerxx's Avatar
    2 bugs to note, both pertaining to the actual phone "app" on my 3GS, after installing iOS4.

    1) (This happens intermittently) When I receive a call or go to check my voicemail, for some reason the screen goes blank and until the other person hangs up or the voicemail ends (or sometimes when i mash on the sleep button), I can't access the rest of the phone. The call/voicemail runs fine, it just disables the entire phone otherwise.

    2) I entered into the Clock app (not sure if it pertains specifically to the clock app) and the green "Press to return to call" bar appeared at the top and the call timer was rapidly cycling random numbers. Note that I was not even remotely in a call at the time. And when i exited the app, the bar disappeared.


    Has anyone else experienced anything like these two occurences?
    Ive been having this problem with the phone app. To me its a big issue because I dial extensions with some numbers I call and cant do that anymore.
    06-22-2010 01:06 PM
  19. Hickory Shampoo#IM's Avatar
    I'm getting a pop-up box saying my Voicemail password is incorrect. Only I've never used a password for my VM, nor do I have a message waiting. This is gonna be irritating when I finally get one.
    If anyone else has this issue, I just called 611 and went to the VM section of the phone tree. Got my password reset and the problem is resolved.
    06-22-2010 01:07 PM
  20. slim24#IM's Avatar
    the only bug i have is that all my photos in my camera roll are gone but when i sync my phone it says i have 67 photos on my iphone 3g
    06-22-2010 01:14 PM
  21. RocketmanNY's Avatar
    2 bugs to note, both pertaining to the actual phone "app" on my 3GS, after installing iOS4.

    1) (This happens intermittently) When I receive a call or go to check my voicemail, for some reason the screen goes blank and until the other person hangs up or the voicemail ends (or sometimes when i mash on the sleep button), I can't access the rest of the phone. The call/voicemail runs fine, it just disables the entire phone otherwise.

    2) I entered into the Clock app (not sure if it pertains specifically to the clock app) and the green "Press to return to call" bar appeared at the top and the call timer was rapidly cycling random numbers. Note that I was not even remotely in a call at the time. And when i exited the app, the bar disappeared.


    Has anyone else experienced anything like these two occurences?
    ERRORCODE616
    I got the same 'error' as you had with #2. Entered the clock app, got all the crazy stuff at the top. Exited then relaunched to app and all was fine. Very strange, thought I was the only one to have this.
    06-22-2010 01:34 PM
  22. Calavera302's Avatar
    Experienced the voicemail bug, fixed it by calling 611 and resetting my password.

    Experiencing the GMail exchange problems (with mail only, contacts and calendar seem to be working). Getting mail manually, and getting push notifications are only working very intermittently.

    Also seeing a problem when I go to the "Places" button in the Photos App. I get no map data at all, just the gray gridlines. I see the pushpins roughly where they should be relative to each other, and they correspond to the right photos, but the map data doesn't load. I'm on a 3GS over 3G network. It doesn't even look like the photos app is trying to access the network (no spinning data wheel at the top).

    The Maps app works fine.
    06-22-2010 01:44 PM
  23. ERRORCODE616's Avatar
    I wonder why it was specifically the clock app. That error doesn't bother as much as amuse me.

    But yeah, as to the first error that completely disables the phone until the call/voicemail is over on the other end, that NEEDS to get fixed and soon. especially in cases with automated calls, the keypad is necessary, among other things.

    Callin' you out, Apple.
    06-22-2010 02:22 PM
  24. smileyboy's Avatar
    Well, i had to set my phone up as new and reinstall everything. I was jailbroken brefore, FYI. But I was able to get all my text messages back on my phone I used this link, http://forums.macrumors.com/showpost...42&postcount=7
    Also 3G and VVM works now.
    06-22-2010 02:39 PM
  25. pilotcap#AC's Avatar
    I upgraded from 3.13 on my iPhone 3GS/32GB, factory unlocked and simlock free. Update went smoothly and quick, restore of data and apps, too. Just connected, hit "update" and left the phone alone for the process. Finished after about 20 minutes. Did a normal reboot (holding down the on/off switch, red slider appeared, switched off, waited ten seconds, started again).

    To all people experiencing issues with no data connection, no MMS or no Internet after upgrade:
    I lost my network and APN settings for the wireless network. Therefore, data connection was over Wi-Fi only. Nor Mail nor Safari via 3G or EDGE.

    Opening Preferences/Network solved the problem: The APN settings and MMS settings were gone and blank. I fetched and entered the values from my mobile network provider, and all was perfect again.

    General findings: Smooth. Nice. Works stable and without any issues. Bluetooth connected earphones were a little mute in the beginning, but there is a new volume control for this on the iPhones iPod app.

    Quitting apps is a bit weird:
    Double click button, hold active app til it "wobbles", touch "close" button.
    06-22-2010 02:44 PM
404 ... 678910 ...
LINK TO POST COPIED TO CLIPBOARD