1. AshDeezy's Avatar
    Hey guys

    For some reason, Loopt, MySpace, and a few others I have been downloading have the wrong app pictures. Loopt for example looks like Shazam, Google app looks like a picture of earth with rings around it.

    Anyone have any idea what is going on? The pics are kind of grayed out too.
    06-20-2009 11:41 PM
  2. AshDeezy's Avatar
    come on guys someone has to know about this...
    06-21-2009 02:21 AM
  3. TheRealJDM#IM's Avatar
    Restore your phone.
    06-21-2009 03:37 PM
  4. APPCRITICal's Avatar
    Yeh I had this when I jailbreak beta 5. Restored to 3.0 Release and its fine now.
    06-22-2009 04:55 AM
  5. iphonecutie's Avatar
    Try to download a theme from cydia and then go to winterboard and apply it. The icons should change. I had the same problem earlier after i jailbroke mine and it worked after that. Hope this helps for u.
    06-22-2009 03:10 PM
  6. JackSpadesSI's Avatar
    I'm having this same problem, too. I've never heard of (and therefore obviously never done a) "jailbreak". I have a 32 GB iPhone 3G S, running OS 3.0.

    This is happening with two of my apps. One of them looks like the app in the same spot on the screen in the previous page, the other looks like an app that I deleted over a week ago.

    If it matters, this started happening yesterday right when I lost my Edge data connection for no reason. The Edge signal has since come back, but the apps still look wrong.

    What I've tried: deleting the apps and reinstalling them from the iPhone's app store. While they're re-downloading they have the correct picture but switch as soon as they're installed.
    07-23-2009 08:24 AM
  7. Ipheuria's Avatar
    Try unchecking the app in itunes and sync so it removes the app. Then power off the phone for a minute or two power back up and check the app in Itunes and sync to restore the app. I have never had the problem but just a thought it may work.
    07-23-2009 08:57 AM
  8. xultar's Avatar
    I've had the same issue with Shazam.
    07-23-2009 09:56 PM
  9. denness544's Avatar
    I have the same problem with some apps. My phone is a 3gs and not jailbroken.
    07-24-2009 01:23 AM
  10. Kuuga's Avatar
    Me too, i installed an online game and the icon is Shazam !!! Did everything what the above said, that icon hasn't change. I have a 3GS and its not jailbreak!!!
    07-25-2009 03:56 AM
  11. lgreenberg's Avatar
    It's a known bug in 3.0
    07-25-2009 05:37 AM
  12. big9erfan's Avatar
    It's a known bug in 3.0
    This. It has nothing to do with being jailbroken or anything like that, it's a bug in 3.0 that will hopefully be addressed in 3.1.
    07-26-2009 12:49 PM
  13. javanutsy's Avatar
    Glad I'm not the only one. I have the 16gb 3GS running 3.0.1. Non-jailbroken. My Shazam looks like Pandora... :|
    08-28-2009 02:38 AM
  14. tproctor83's Avatar
    Today I just noticed that the Yelp icon has parts of HarborMater, Chipolte has Discover's icon, and craigsphone has a mix of flixster and fotomuse. When I search them in spotlight they come up with completely different icons. Interesting note, all of this occurred on the 11th screen of the phone and were the last three apps to be installed on my iphone 3GS 32GB running 3.01
    08-29-2009 10:14 AM
LINK TO POST COPIED TO CLIPBOARD