1. itmozart's Avatar
    I have an iPhone 3G 2.1 jailbroken, which works well, but when I try to install iMapMy[whatever], I get an error message saying the application is not compatible with my iPhone.

    What's likely to be the problem? I couldn't find anything similar around the net.

    Thanks!
    Saverio
    12-17-2008 06:48 PM
  2. msbaylor's Avatar
    It could very well be firmware incompatability. Some app developers that have made updates to their apps for 2.2 but accidently built against 2.1

    Anyone else have 2.1 with this problem?
    12-17-2008 07:54 PM
  3. bman7163's Avatar
    I have tried to download two apps so far that are saying they are "not compatible with this iphone". The first one I found not compatible was allrecipes.com

    I am still running jailbroken 2.1. I went to allrecipes website and found out that 2.2 is required for this app.

    I then found that accuweather app is also not compatible. I am also thinking this is 2.2 related.

    Right now I don't really feel like wiping my phone out and starting all over.
    12-22-2008 07:09 PM
LINK TO POST COPIED TO CLIPBOARD