1. robnhl's Avatar
    I'm new to the iPhone 7 Plus and I'm having an issue that is driving me nuts.

    A couple of times per day my WiFi connection just stops working. The device still shows that it is connected to my WiFi network but there is just a spinning dial next to the WiFi indicator and I can't connect to the internet. I can toggle airplane mode and everything goes back to normal.

    Other devices on my home network (5 GHz mixed N/AC) do not have this issue. This includes the Android phones I use everyday (Moto Z2 Play and Galaxy S7).

    I've tried a factory reset and installing the public beta. Neither made any difference. Any ideas?
    01-11-2018 03:58 PM
  2. TripleOne's Avatar
    Go to Settings - Wifi - Forget This Network, and then reconnect to it.

    Hopefully, that will fix the problem.
    01-11-2018 06:26 PM
  3. robnhl's Avatar
    Go to Settings - Wifi - Forget This Network, and then reconnect to it.

    Hopefully, that will fix the problem.
    I had tried that, but still face the issue. Latest thing I've done is to do a phone reset through iTunes. I'll be watching very closely today to see if the problem reappears.
    01-12-2018 07:05 AM
  4. TripleOne's Avatar
    I had tried that, but still face the issue. Latest thing I've done is to do a phone reset through iTunes. I'll be watching very closely today to see if the problem reappears.
    Got it. Please keep us updated and I hope the problem won’t resurface.
    01-12-2018 07:38 AM
  5. robnhl's Avatar
    So iTunes reset did nothing to change the behavior. What I've done is replaced my Spectrum router with the Nova mesh Wifi system and that seems to work better. Still can't figure out why this was only happening to iPhone, but for now it seems all is well.
    Yesterday 07:27 AM
  6. tadpoles's Avatar
    I'm new to the iPhone 7 Plus and I'm having an issue that is driving me nuts.

    A couple of times per day my WiFi connection just stops working. The device still shows that it is connected to my WiFi network but there is just a spinning dial next to the WiFi indicator and I can't connect to the internet. I can toggle airplane mode and everything goes back to normal.

    Other devices on my home network (5 GHz mixed N/AC) do not have this issue. This includes the Android phones I use everyday (Moto Z2 Play and Galaxy S7).

    I've tried a factory reset and installing the public beta. Neither made any difference. Any ideas?
    I have had issues with my 5Ghz when I had a 7 Plus. So I created a 2.4Ghz network and it worked great. My understanding is that 5Ghz can potentially give you better speed at the expense of range. Are you able to to establish a 2.4Ghz network on your router and see if that makes it better for you like it did for me?
    Yesterday 07:56 AM

Similar Threads

  1. Replies: 16
    Last Post: Yesterday, 11:00 PM
  2. Why is duck duck go not working on my 2017 iPad?
    By Wotchered in forum Ask a Question
    Replies: 4
    Last Post: 01-17-2018, 09:51 AM
  3. Replies: 2
    Last Post: 01-11-2018, 06:13 AM
  4. Replies: 3
    Last Post: 01-10-2018, 01:26 PM
  5. How to stop your iPhone from tracking locations you frequently visit
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 01-09-2018, 01:10 PM
LINK TO POST COPIED TO CLIPBOARD