1. Johnny Naorem's Avatar
    I have an iphone 6s and i have been using for around 1 year perfectly. But now it gets so much lag under low battery and when it is connected to the charger it goes off and works smoothly. And also i had upgraded to 10.3.3 version n thought this might be the reason. Any tips or suggestions.??
    Last edited by Johnny Naorem; 08-16-2017 at 07:27 AM.
    08-16-2017 06:40 AM
  2. Spencerdl's Avatar
    Welcome to iMore Johnny and THANKS for joining. Have you tried a hard reboot. Hold down the power button and down volume button at the same time until you see the Apple () logo and release. Allow the iPhone to reboot. See if that helps.
    08-16-2017 07:57 AM
  3. Johnny Naorem's Avatar
    Thanks for the feed back.. I tried but nothing change. What to do?
    08-16-2017 08:26 AM
  4. Spencerdl's Avatar
    It could be a bad battery. You might have to make a Genius Bar appointment with the Apple Store and have a diagnostic done on your device.
    08-16-2017 08:47 AM
  5. Johnny Naorem's Avatar
    Thanks. Hope it works
    08-16-2017 09:01 AM
  6. Spencerdl's Avatar
    Thanks. Hope it works
    Keep us informed. Good luck
    08-16-2017 09:28 AM

Similar Threads

  1. The 'Curve' is Twelve South's latest MacBook stand and it's gorgeous
    By iMore.com in forum iMore.com News Discussion
    Replies: 1
    Last Post: 08-15-2017, 09:46 PM
  2. How to mute keywords and filter out "eggs" on Twitter
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 08-15-2017, 06:40 PM
  3. Replies: 0
    Last Post: 08-15-2017, 04:30 PM
  4. Why Amazon should password-protect its Alexa app
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 08-15-2017, 12:10 PM
  5. Join the discussion: It's 2017; do you still rock an iPod?
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 08-15-2017, 08:10 AM
LINK TO POST COPIED TO CLIPBOARD