1. Michael#IM's Avatar
    When my phone is set to 3G it ignores certain cell towers that definately belong to my carrier. For example i could be near a tower but only have one bar from a tower miles away. However if i select airplane mode and un select it will connect straight up to it. Works perfectly in 2G. Any ideas?
    02-21-2016 07:34 AM
  2. Just_Me_D's Avatar
    What specific phone model do you have?
    02-21-2016 09:05 AM
  3. scruffypig's Avatar
    When my phone is set to 3G it ignores certain cell towers that definately belong to my carrier. For example i could be near a tower but only have one bar from a tower miles away. However if i select airplane mode and un select it will connect straight up to it. Works perfectly in 2G. Any ideas?
    Have you reported those towers to your phone company?
    02-21-2016 09:41 AM
  4. Michael#IM's Avatar
    Not yet seems it could be a network problem, did some testing with a friends Samsung phone who is on the same network. We were beside one of the said towers and signal very low, eventually did connect.
    02-21-2016 11:37 AM
  5. Michael#IM's Avatar
    This phone is driving me crazy now. Got on to the carrier and they said they'd check if there was any problems. A few hours later they came back saying "traffic flow is normal on the cells and no faults are showing after testing". So i changed the sim card and it's still the same. It ignores the same few towers unless i toggle the airplane mode and i then get lovely full signal. I did a restore and a network settings reset still no joy... anyone any ideas, must be the phone??? it's a 6s.

    Not sure if this would make a difference my phone was on another carrier and i recently changed to my current carrier ( phone bought directly from Apple unlocked though)
    02-23-2016 05:00 PM
  6. robertk328's Avatar
    What wireless carrier is it? Have you gone to Settings > General > About to check for carrier updates?
    02-23-2016 09:25 PM
  7. Michael#IM's Avatar
    Just an update , i got the phone replaced and the problem still persists, interesting! I have a femtocell and it doesn't like to auto connect to that either when in close range. You could have the phone resting against it and it would still prefer the weaker signal from a tower in the town. But once you toggle the airplane mode it connects.

    What i have noticed ( through field test mode) it doesn't like to change from towers with a specific UARFCN that my phone has no problems with to towers that have a different UARFCN including my femtocell (unless signal is nearly lost or airplane mode toggle), weird! Maybe the iphone isn't fully compatible with all networks or that's the way 3g works :-/
    02-29-2016 03:14 PM
  8. Rockdog97's Avatar
    what model iPhone do you have? How do you know which tower the phone is getting signal from?
    02-29-2016 03:57 PM
  9. Michael#IM's Avatar
    Iphone 6s A1688. I can tell which tower i'm connected to with the field test mode :-)
    02-29-2016 05:17 PM

Similar Threads

  1. Is 2.5Ghz worth the phone upgrade?
    By richard_rsp in forum Sprint
    Replies: 6
    Last Post: 03-29-2016, 10:28 AM
  2. Landscape or portrait
    By jaleelhamid in forum iPhone 6s Plus
    Replies: 23
    Last Post: 02-26-2016, 06:14 PM
  3. How do I make my phone ring when I receive a call?
    By iMore Question in forum General Apple News & Discussion
    Replies: 4
    Last Post: 02-21-2016, 08:42 AM
  4. Should I get the gold or silver 6s?
    By iMore Question in forum iPhone 6s
    Replies: 1
    Last Post: 02-20-2016, 11:36 PM
LINK TO POST COPIED TO CLIPBOARD