1. acerace113's Avatar
    I just got my iPhone 6S, and for some reason it's not staying connected to LTE in my area. I have band 17 and band 4 coverage for LTE with my carrier Bell Canada. I'm trying to figure out if it's the phone or my carrier that the issue is from. I already tried restoring it once and did any carrier profile updates. I'm just not sure what else to try.

    Sent from my 6th gen iPod touch using Tapatalk
    09-25-2015 11:15 AM
  2. acerace113's Avatar
    Just tried the SIM card that came with my 6S in my 5S and I get LTE with no problems. So I guess it might be the phone.


    Sent from my 6th gen iPod touch using Tapatalk
    09-25-2015 11:38 AM
  3. RECON1's Avatar
    Just tried the SIM card that came with my 6S in my 5S and I get LTE with no problems. So I guess it might be the phone.


    Sent from my 6th gen iPod touch using Tapatalk
    Have you tried to re-set network settings?
    09-25-2015 03:15 PM
  4. acerace113's Avatar
    Have you tried to re-set network settings?
    Yes
    I also have restored my phone twice now. It still tries to connect to LTE but it will disconnect after it connects to LTE. I'm going to my carrier store tomorrow to try a different SIM card.


    Sent from my iPhone 5S using Tapatalk
    09-25-2015 03:20 PM
  5. Ritam Brkljacic's Avatar
    Try going into your location services and disabling cellular network search similar to Wi-Fi networking. Might help might not but it might be worth a try or stationary oh you turn it back on and call your cellular carrier
    09-25-2015 03:29 PM
  6. acerace113's Avatar
    Try going into your location services and disabling cellular network search similar to Wi-Fi networking. Might help might not but it might be worth a try or stationary oh you turn it back on and call your cellular carrier
    I've tried that too and no difference.


    Sent from my iPhone 5S using Tapatalk
    09-25-2015 04:03 PM
  7. acerace113's Avatar
    I think I've tried everything I can do so far. People can keep suggesting stuff in case I missed something. The only thing left to do is call my carrier, try a new SIM card, or go to the Apple Store and get a replacement phone.


    Sent from my iPhone 5S using Tapatalk
    09-25-2015 04:05 PM
  8. noaim's Avatar
    I think I've tried everything I can do so far. People can keep suggesting stuff in case I missed something. The only thing left to do is call my carrier, try a new SIM card, or go to the Apple Store and get a replacement phone.


    Sent from my iPhone 5S using Tapatalk
    how much signal do you get with the old phone on LTE? I know one of the updates is to save battery by not staying connected to low signals.. may be something not sure though
    09-25-2015 04:07 PM
  9. acerace113's Avatar
    how much signal do you get with the old phone on LTE? I know one of the updates is to save battery by not staying connected to low signals.. may be something not sure though
    4-5 bars with band 17 LTE, 2-4 bars with band 4 LTE and that's with my 5S.


    Sent from my iPhone 5S using Tapatalk
    09-25-2015 04:09 PM
  10. acerace113's Avatar
    Ok I just tried the SIM card that came with my 6S in my 5S and it's working fine with no issues. LTE is not disconnecting from my 5S but the same SIM card in my 6S and LTE disconnects. I'm starting to think its the phone.


    Sent from my iPhone 5S using Tapatalk
    09-25-2015 05:08 PM
  11. noaim's Avatar
    Ok I just tried the SIM card that came with my 6S in my 5S and it's working fine with no issues. LTE is not disconnecting from my 5S but the same SIM card in my 6S and LTE disconnects. I'm starting to think its the phone.


    Happy it worked out!
    Sent from my iPhone 5S using Tapatalk
    i always recommend using new sim if you can as those are programmed to the carrier and things change with them.. not always but sometimes.
    09-25-2015 05:21 PM
  12. acerace113's Avatar
    i always recommend using new sim if you can as those are programmed to the carrier and things change with them.. not always but sometimes.
    The SIM card that came with the 6S is new... And I tried it in both my 6S and 5S and the only one that didn't have issues is the 5S... I think it's the phone but I'll going to try a SIM card from a friends 6 and a carrier store just to be sure.


    Sent from my iPhone 5S using Tapatalk
    09-25-2015 05:33 PM
  13. acerace113's Avatar
    Ok, just tried my friends SIM card from his 6 in my 6S and my 6S still has the LTE issue so I guess I might have to go to an Apple Store.


    Sent from my iPhone 5S using Tapatalk
    09-25-2015 06:58 PM
  14. noaim's Avatar
    Ok, just tried my friends SIM card from his 6 in my 6S and my 6S still has the LTE issue so I guess I might have to go to an Apple Store.


    Sent from my iPhone 5S using Tapatalk
    sorry to hear that.. At least it happened right away so that its not out of warranty.. hopefully they are able to replace right away
    09-25-2015 07:16 PM
  15. acerace113's Avatar
    sorry to hear that.. At least it happened right away so that its not out of warranty.. hopefully they are able to replace right away
    I might try my carrier store first to see if they will swap it since it's closer


    Sent from my iPhone 5S using Tapatalk
    09-25-2015 07:22 PM
  16. acerace113's Avatar
    Just few updates:
    Tried another SIM card from my carrier didn't work. They couldn't swap my phone cause I ordered it online and also they had no 128 GB iPhone 6S of any colour in store.
    Contacted Apple support and got my issue sent to Apple engineers, they are going to look into it. Still waiting to hear back from them.


    Sent from my 6th gen iPod touch using Tapatalk
    09-27-2015 08:38 AM
  17. BLiNK's Avatar
    i ran into the same issue last night. i seriously thought it was a network issue where i was, now i am beginning to wonder.

    i'll be keeping an eye on this thread and will update my scenario as well. i really hope this is not the beginning of a "bad batch"
    09-27-2015 09:01 AM
  18. acerace113's Avatar
    i ran into the same issue last night. i seriously thought it was a network issue where i was, now i am beginning to wonder.

    i'll be keeping an eye on this thread and will update my scenario as well. i really hope this is not the beginning of a "bad batch"
    My issue started as soon as I got the phone. For the record when was your phone manufactured?


    Sent from my 6th gen iPod touch using Tapatalk
    09-27-2015 09:10 AM
  19. acerace113's Avatar
    Got a reply back from Apple support, they wanted me to try a few other things like try my SIM card in a different phone (which my SIM card works perfectly in a different phone) try a different SIM card from another phone (which I did and still had the same issue). So now I have to wait again to hear back from them to see what they want me to do next.


    Sent from my 6th gen iPod touch using Tapatalk
    09-29-2015 04:01 PM
  20. acerace113's Avatar
    Got another reply from apple support saying to get my phone exchanged at an Apple Store. I guess they think it's a hardware issue.


    Sent from my iPhone 6S using Tapatalk
    10-01-2015 08:19 PM
  21. acerace113's Avatar
    Got my phone exchanged at the Apple Store still having LTE issues where I live. I think it might be the carrier towers in my area.


    Sent from my 6th gen iPod touch using Tapatalk
    10-05-2015 07:16 AM
  22. acerace113's Avatar
    Just want to give an update;
    I called bell and network technicians are looking into my LTE issue with my 6S where I live but I found something very interesting this morning. When I'm connected to band 17 LTE my phone won't drop to 3G at all but as soon as it picks up the band 4 LTE tower in my area it will drop to 3G almost instantly.
    *note: I used field test mode to find out what band I'm connected to.


    Sent from my 6th gen iPod touch using Tapatalk
    10-20-2015 08:45 AM
  23. Sugrat's Avatar
    I've been having a similar issue with my 6s, 50% of the time when I look at my phone it's on 3G and will take ages to get a LTE signal. I went to a Verizon store and actually replaced the SIM card but the problem still happens. Never had this problem with any of my previous iPhones and my wife's new iPhone 6s+ is working fine in the same area.

    Let us know what the carrier finds out.
    10-29-2015 01:55 AM
  24. acerace113's Avatar
    I've been having a similar issue with my 6s, 50% of the time when I look at my phone it's on 3G and will take ages to get a LTE signal. I went to a Verizon store and actually replaced the SIM card but the problem still happens. Never had this problem with any of my previous iPhones and my wife's new iPhone 6s+ is working fine in the same area.

    Let us know what the carrier finds out.
    My carrier keeps telling me it's a problem with the phone. Plus they can't find anything wrong with the towers in my area but they also won't tell me what they did to test the issue. I've already had my phone replaced my Apple near the start of October and I still have the exact same issue. My phone will connect to band 17 LTE and stay connected no problem but as soon as it detects band 4 LTE it will try to connect to it but it will drop to 3G. And I've tried everything that I can do to try and fix the issue the only thing left that it can be is a carrier issue.
    10-29-2015 09:21 AM
  25. GatsbyGlen's Avatar
    Should I see an LTE icon when connected to WiFi? I don't, but I do when WiFi is disconnected. I also have the found setup to use LTE for both voice and data.
    10-29-2015 09:32 AM

Similar Threads

  1. Official iPhone 6s Wallpaper Thread
    By James Falconer in forum iPhone 6s
    Replies: 33
    Last Post: 12-01-2017, 04:43 PM
  2. Share your iPhone 6s Homescreen!
    By James Falconer in forum iPhone 6s
    Replies: 289
    Last Post: 10-10-2017, 09:30 AM
  3. iPhone 6 lightning port defect
    By bchiong in forum Ask a Question
    Replies: 19
    Last Post: 01-09-2016, 08:23 AM
  4. How to create gifs of Live Photos and share them to Instagram and Facebook
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 09-25-2015, 11:12 AM
  5. What spec of iPhone 6s or iPhone 6s Plus did you order?
    By James Falconer in forum iPhone 6s Plus
    Replies: 0
    Last Post: 09-25-2015, 11:00 AM
LINK TO POST COPIED TO CLIPBOARD