1. iMore Question's Avatar
    My iPhone 6, factory locked to AT&T, refuses to connect to the network even after at least 10 DFU (or iTunes) restores (always setting up as new iPhone). I've tried multiple known-good SIM cards. Of course, I've also tried the obvious such as "Reset Network Settings", getting a new SIM from AT&T, and enabling/disabling various settings such as LTE and roaming options; all wit no avail. My iPhone is out of warranty therefore taking it to Apple isn't an option. I've already replaced the lower Lightning dock connecter assembly which has one antenna, of course. Also replaced the antenna at the far top center of the device on the back side of the motherboard. Absolutely no luck. Any suggestions?
    02-29-2016 12:06 AM
  2. IAmSixNine's Avatar
    Did this happen before or after you took the phone apart? Sounds like you may need to take it in for repair. 3rd party or apple.
    Naturally if this happened after you took it apart you must have missed connecting something internally.
    IF this happened before, are you the original owner? If not check the IMEI with swapa and make sure it hasnt been reported lost / stolen or unpaid.
    02-29-2016 03:43 PM
  3. WilliamCTraylor's Avatar
    IMEI displays properly and does not register as blacklisted. AT&T unlocked the phone last night and I attempted to use a Verizon SIM. The device successfully activated, but still "No Service". I am not the original owner. I've been a cellphone and Mac/PC technician for 10 years in a rural area so there aren't many individuals I can speak to for a second opinion. In my community, if I can't solve the issue or at least provide an answer, customers toss their device. This is probably the 2nd issue in my entire career that I've genuinely not been able to at least find out why. The previous owner had an inexperienced technician work on it. This "technician" replaced the Lighting dock assembly as well as the display, but the "No Service" issue began long after this repair took place. I'm stumped. I believe, however, it must be some non-removable (without desoldering) component on the motherboard. Since it has been opened and "serviced" by someone that didn't know what they were doing, I can not take it to Apple. I'd just love a second opinion on any cost-effective methods of remedying this situation before I begin scrapping it.
    02-29-2016 07:07 PM
  4. IAmSixNine's Avatar
    Using a Verizon SIM in an ATT phone wont help you any. The SIM for Verizon is for the data LTE services. I dont believe it will register voice calls on VoLTE and with out registering the IMEI with Verizon on a CDMA chipset it wont get service.
    ATT or TMO should get you service if its unlocked. Sprint and Verizon should not as it cant register the voice side of the network via CDMA.
    In the original post you mentioned it failed with a working ATT sim. Correct?
    03-01-2016 09:35 AM
  5. WilliamCTraylor's Avatar
    I do realize that popping in a Verizon SIM will not magically remedy the issue. It did, however, successfully make calls, sent text messages, and connect to the cellular data network with that Verizon SIM in my AT&T iPhone 6 Plus which was unlocked on the same evening all without having to contact Verizon. It was done mostly out of curiosity and the need to have it unlocked anyways; just thought I'd add that point in as a sidetone in my previous comment. Thank you, though.

    Correct, it will not connect to the AT&T network with known working SIMs.
    03-01-2016 01:57 PM
  6. IAmSixNine's Avatar
    Interesting it made calls. Must have used VoLTE to do it.
    its always possible its a buggy phone and nothing we can do will fix it.
    I had one come thru my office the other day and Siri wouldnt work. No voice input worked.
    BUT the voice recorder worked, recorded audio in videos, and phone calls worked.
    But if you tried to talk to Siri she would not hear a peep.
    03-01-2016 02:59 PM
  7. WilliamCTraylor's Avatar
    I had an iPhone 6 with that EXACT same Siri issue. A restore and not restoring from its backup seemed to clear things up. However, this one was jailbroken so that may very well have been the culprit.
    As another side note, I have very poor service at home so I keep LTE off. It was also off with the Verizon SIM in my 6 Plus when it made calls.
    I've almost given up. I may take my chances sending it to Apple and hearing their quote. I'm not sure of any other options besides scrapping it.
    03-02-2016 02:28 AM
  8. IAmSixNine's Avatar
    I wish i could help more.
    03-02-2016 10:21 AM

Similar Threads

  1. Replies: 3
    Last Post: 03-20-2016, 03:23 PM
  2. Why didn't I yet get my iPhone 6 ???
    By mtulahappi in forum iPhone 6
    Replies: 3
    Last Post: 03-03-2016, 07:31 PM
  3. Replies: 2
    Last Post: 02-28-2016, 09:14 PM
  4. My text messages don't alert on each response in a thread, why?
    By iMore Question in forum General Apple News & Discussion
    Replies: 1
    Last Post: 02-28-2016, 08:22 PM
  5. Replies: 1
    Last Post: 02-28-2016, 05:46 PM
LINK TO POST COPIED TO CLIPBOARD