1. iMore Question's Avatar
    i recently changed carriers and updated to a iPhone 6. My children also updated to iPhone 6 and are on the same carrier. My sister also updated to a iPhone 6 plus but is on another carrier. My children have no problem texting my sister. I seem to have the problem. She has not blocked me and I have not blocked her. When I text a message I get the message ( phone number in blue with 6 digits) followed by "Error Invaild Number. Please resend using a valid 10 digit mobile number or valid short code." Her number is in my contact with 10 digits. Also at the top where the name should be is [redacted]. I have reset my phone, reset network settings, removed her from my contacts, deleted all text from her, rebooting each time. I also got another iPhone 6 thinking it maybe the phone itself. When I received the 2nd iPhone 6 I did a back up from the 1st iPhone 6 phone and restored data to my new iPhone 6. I was able to text her at that time. How ever I noticed I did not get all my information back. So I went back and restored iPhone from a earlier update. Since then I am not able to send a text to my sister. Please help!!! My email is redacted. Thank you.
    Last edited by Just_Me_D; 05-16-2015 at 12:47 PM.
    04-18-2015 08:28 PM
  2. Just_Me_D said: Best Answer

    Delete the contact information for your sister, reboot the iPhone and then create a new contact for her with the correct information.
  3. Just_Me_D's Avatar
    Delete the contact information for your sister, reboot the iPhone and then create a new contact for her with the correct information.
    04-18-2015 09:18 PM
  4. tlo07's Avatar
    I had that happen once when I accidentally sent a text to my mom's land line instead of her cell. Do you have the correct number?


    Sent from my iPad using Tapatalk HD
    05-31-2015 06:33 PM

Similar Threads

  1. Just switched from the 6 to the 6 plus and what a difference
    By WolfBanner87 in forum iPhone 6 Plus
    Replies: 39
    Last Post: 04-30-2015, 08:31 AM
  2. How do I set iPhone alarm to go into auto snooze mode?
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 04-18-2015, 08:15 PM
  3. Replies: 1
    Last Post: 04-18-2015, 08:06 PM
  4. Time lapsed video to normal speed
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 04-18-2015, 06:16 PM
LINK TO POST COPIED TO CLIPBOARD