1. unstoppablekem's Avatar
    First, iMessages are sending from my email. Is this maybe because this is my first iPhone, and I usually send iMessages from my iPad and Mac with my email?

    Second, I synced contacts from both of my Microsoft accounts, and I have many duplicates and even 3 or four! How do I fix this??

    These are bothering me A LOT! Once I am able to fix these though, I'll be a very happy camper.
    09-20-2014 01:54 AM
  2. HankAZ's Avatar
    First, iMessages are sending from my email. Is this maybe because this is my first iPhone, and I usually send iMessages from my iPad and Mac with my email?

    Second, I synced contacts from both of my Microsoft accounts, and I have many duplicates and even 3 or four! How do I fix this??

    These are bothering me A LOT! Once I am able to fix these though, I'll be a very happy camper.
    For iMessage, make sure that you have your phone number set up as one of the "addresses". There are two menu settings, as I recall (phone is in the other room charging) - Send using (or similar text) that lists the email addresses and phone numbers - check what you want to show; and Start New Messages From (again, maybe not the exact wording) - make sure the phone number is checked there. I think that should do it.

    Regarding multiple/duplicate contacts, just make sure that you are only syncing once - not feeding contacts from iCloud AND Microsoft/Outlook. I have seen posts where once the duplicates are there, they are hell to remove because the 2 feeds keep propagating them back and forth.

    Hope that helps, that’s all I got.
    unstoppablekem likes this.
    09-20-2014 02:12 AM
  3. unstoppablekem's Avatar
    For iMessage, make sure that you have your phone number set up as one of the "addresses". There are two menu settings, as I recall (phone is in the other room charging) - Send using (or similar text) that lists the email addresses and phone numbers - check what you want to show; and Start New Messages From (again, maybe not the exact wording) - make sure the phone number is checked there. I think that should do it.

    Regarding multiple/duplicate contacts, just make sure that you are only syncing once - not feeding contacts from iCloud AND Microsoft/Outlook. I have seen posts where once the duplicates are there, they are hell to remove because the 2 feeds keep propagating them back and forth.

    Hope that helps, thats all I got.
    Where is that setting for messages? Can't find it in settings.

    And it seems it doesn't matter either way if iCloud contacts are backed up, it still shows the duplicates. What I'm doing now is deleting the duplicates one by one. Once I finish that, is that possible for that to be transferred to iCloud, so if I get a new iPhone if this one breaks, I won't have to deal with it again?
    09-20-2014 02:18 AM
  4. HankAZ's Avatar
    Where is that setting for messages? Can't find it in settings.

    And it seems it doesn't matter either way if iCloud contacts are backed up, it still shows the duplicates. What I'm doing now is deleting the duplicates one by one. Once I finish that, is that possible for that to be transferred to iCloud, so if I get a new iPhone if this one breaks, I won't have to deal with it again?
    Messages settings is at Settings > Messages > Send & Receive. The two menu items are "You can be reached by iMessage at:" and "Start new conversations from:".

    Regarding the contacts, that’s the tricky part. How are you pulling your contacts into your phone? Using the Settings > Mail, Contacts, Calendars you should only have ONE of your email addresses syncing contacts. Find one that has everything - even if it has duplicates, and stick with it. I’d recommend using an email address that is connected with iCloud. Turn Contacts OFF for all others. Then work on fixing the one that remains. That should do it. I thought I read that you were using iCloud and Microsoft/Outlook (sorry if I got that wrong). But if you are, both sources are populating the lists to the other, and then the other populates back (including duplicates) and it just goes back and forth until it’s a hot mess.
    unstoppablekem likes this.
    09-20-2014 02:35 AM
  5. unstoppablekem's Avatar
    Messages settings is at Settings > Messages > Send & Receive. The two menu items are "You can be reached by iMessage at:" and "Start new conversations from:".

    Regarding the contacts, thats the tricky part. How are you pulling your contacts into your phone? Using the Settings > Mail, Contacts, Calendars you should only have ONE of your email addresses syncing contacts. Find one that has everything - even if it has duplicates, and stick with it. Id recommend using an email address that is connected with iCloud. Turn Contacts OFF for all others. Then work on fixing the one that remains. That should do it. I thought I read that you were using iCloud and Microsoft/Outlook (sorry if I got that wrong). But if you are, both sources are populating the lists to the other, and then the other populates back (including duplicates) and it just goes back and forth until its a hot mess.
    For iMessage, I have that enabled, but my brother still says it's my email. Weird!

    And for contacts, I found this awesome app called Contacts Duster Pro. Fixed everything, took only 30 seconds!
    09-20-2014 02:57 AM
  6. HankAZ's Avatar
    For iMessage, I have that enabled, but my brother still says it's my email. Weird!

    And for contacts, I found this awesome app called Contacts Duster Pro. Fixed everything, took only 30 seconds!
    I’ve not tried this personally, but on the messages thing, you might try turning OFF the email address on your phone and see how it goes. Play with turning iMessage off and then back on. You’re right, it’s a weird one.
    09-20-2014 03:12 AM
  7. unstoppablekem's Avatar
    Ive not tried this personally, but on the messages thing, you might try turning OFF the email address on your phone and see how it goes. Play with turning iMessage off and then back on. Youre right, its a weird one.
    It won't let me, says cannot be removed. In doing this through settings for messaging, not mail settings.
    09-20-2014 03:14 AM
  8. LVMHgirl's Avatar
    ^This happened to my mom yesterday after the update on her 5. She had not been using iMessage before. The update defaulted iMessage to "on" and the "start conversations from" was checked as her iCloud email which she never uses.

    So I told her to delete the conversation that she had started with me while unknowingly on iMessage (and to make sure that the phone number was checked to start conversations) and then start a new convo with me.
    Her iPad then asked if her # was approved to be added for iMessage.

    Then all was fine and was able to text like normal (but I think she will go back to using SMS text only &#128540.

    Hope this helps with your issue. 😊
    09-20-2014 04:27 AM
  9. Guacho's Avatar
    I had some issues with my wife's iPhone 6 and iMessage, it wouldn't send messages between iOS devices, I did turn off iMessages in her previous iPhone before wiping it, after a few resets it finally worked
    09-20-2014 06:50 AM
  10. iBright's Avatar
    Yeah it happened to me as we'll and hag I did was just turn off iMessage n on again and will ask you to activate with your phone number. That worked for me.


    iPhone 5S Gold ( iOS 7.1.2 )
    09-20-2014 07:53 AM
  11. Designed4Him's Avatar
    I found a fix for my issue. When I added my email to my phone everything that was synced to my Apple ID had my phone number listed and so I just selected my phone number was I chose that it was ok to be reached. Now my number is on all my iDevices.
    09-20-2014 09:15 AM

Similar Threads

  1. Post Pictures & Video Taken With Your iPhone 6!
    By EmceeGeek in forum iPhone 6
    Replies: 381
    Last Post: 09-18-2017, 03:42 AM
  2. Adventures in iPhone Cases!
    By SeanHRCC in forum iPhone 6 Plus
    Replies: 25
    Last Post: 09-20-2014, 02:28 PM
  3. use my pc s internet from my iphone
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 09-20-2014, 01:09 PM
  4. use my pc s internet from my iphone
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 09-20-2014, 09:40 AM
  5. Battery life of iPhone 5S after updating to iOS 8
    By Parth Joshi1 in forum Ask a Question
    Replies: 3
    Last Post: 09-20-2014, 03:27 AM
LINK TO POST COPIED TO CLIPBOARD