1. blacalameto's Avatar
    So I have iPhone 6 plus 64GB that lately, has been very laggy. It takes it a good second to rotate the screen and at times the screen is not responsive when I go to swipe or click on an app. Eventually the screen catches up to my behavior but I can't believe that a year old phone is running this way. Could this be a software issue? Anyone else noticing this? Any suggestions?

    Thanks!
    11-14-2015 03:45 PM
  2. missy8787's Avatar
    I've been noticing that with mine too. And this is my second replacement phone cus of the lag. When I brought it to my carrier they said it was a software problem.
    11-15-2015 01:29 PM
  3. mumfoau's Avatar
    Ok I thought it was just me. I went to Apple about 2 weeks ago and get a replacement. I reboot my phone every Sunday night as a habit so that has helped a fair amount. Been using iOS devices since the 4S and I've never experienced this type of issue with them before. Great track record
    11-15-2015 08:06 PM
  4. blacalameto's Avatar
    I'm hoping a software update will fix this. I just went out of warranty oh my device, unfortunately.
    11-16-2015 11:15 AM
  5. moxon64's Avatar
    The lag is really bad and I hope the patch come soon. Did anyone try the public betas for 9.2?
    11-16-2015 11:27 AM
  6. Ooltewah_Vol's Avatar
    The lag is really bad and I hope the patch come soon. Did anyone try the public betas for 9.2?
    I am on the public beta and 9.2 has resolved those issues. I really struggled with my 6 plus up to that point. Everything is back to being as smooth as it was on iOS 8.
    mumfoau and moxon64 like this.
    11-16-2015 12:37 PM
  7. moxon64's Avatar
    I'm on my way to install 9.2 beta.

    I am on the public beta and 9.2 has resolved those issues. I really struggled with my 6 plus up to that point. Everything is back to being as smooth as it was on iOS 8.
    11-16-2015 12:42 PM
  8. Ooltewah_Vol's Avatar
    I'm on my way to install 9.2 beta.
    Let me know how it goes!
    11-16-2015 01:06 PM
  9. blacalameto's Avatar
    Let me know how it goes!
    I installed the 9.2 beta on mine and can't confirm it appears to have fixed any lag issues. It runs a lot better. I was hesitant to put a beta version on my main device but I'm glad I did.
    mumfoau likes this.
    11-21-2015 02:53 PM
  10. robertk328's Avatar
    9.2 is solid! I would imagine the update should release soon, its been very good lately.
    mumfoau likes this.
    11-21-2015 07:43 PM
  11. blacalameto's Avatar
    I installed the 9.2 beta on mine and can't confirm it appears to have fixed any lag issues. It runs a lot better. I was hesitant to put a beta version on my main device but I'm glad I did.
    I can't edit this for some reason. I obviously meant "I can confirm".

    My iPhone 6 Plus flies once again...as it should!
    11-21-2015 09:16 PM
  12. moxon64's Avatar
    I installed 9.2 and it worked wonders. I'm gonna test the beta 9.2.1 and see if there are any improvements with lag.
    12-21-2015 05:45 PM

Similar Threads

  1. Why won't my iPhone 5c connect to my Macbook Pro?
    By iMore Question in forum iPhone 5c
    Replies: 0
    Last Post: 11-14-2015, 02:49 PM
  2. Netflix will not open on my IMAC error says to turn off Airplay
    By iMore Question in forum Ask a Question
    Replies: 0
    Last Post: 11-14-2015, 01:45 PM
  3. On my iPhone 5s, why can't I see any pics on photos?
    By iMore Question in forum iPhone 5s
    Replies: 1
    Last Post: 11-14-2015, 01:10 PM
  4. Which one is nice silver or rose gold 6s plus?
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 11-14-2015, 10:55 AM
LINK TO POST COPIED TO CLIPBOARD