1. aznhomieboi1689's Avatar
    So I have TMobile and currently in the DFW metroplex where LTE is fairly reliable and fast. It used to be that way at least until recently. I used SpeedTest by Ookla app to test the LTE speed and it says it's supposed to be 27 Mbps download speed. However it doesn't feel like that. Even though my results say this, I recently have issues with loading websites (very slow), I cant even load any videos (even though the supposed speed should be faster than my WiFi) and it is just slow. I don't understand why it would be slow if the SpeedTest app say otherwise. Could the app be misleading? I've done the test a couple of times with similar results. Anyone have any ideas why it says the speed is fast but the actual experience is slow?

    btw I can't paste the results link from SpeedTest since my phone is also being retarded and not letting me paste the copied texts from clipboard...
    01-04-2015 02:04 PM
  2. Reparkable's Avatar
    Why not take a screenshot of your results and then upload the pic here?
    01-04-2015 02:14 PM
  3. applejosh's Avatar
    I'd try clearing the Safari cache/history and doing a hard reset (press and hold power & home buttons until the Apple screen appears).
    01-04-2015 02:17 PM
  4. infinite_loop's Avatar
    This has happened to me in the past. It's probably because you have used up all of your data for that billing period.
    01-04-2015 04:53 PM
  5. zerog46's Avatar
    Yes may be getting throttled.
    01-04-2015 09:26 PM
  6. FaisDogg's Avatar
    This is what mines like, it feels the same even with HD video playback LTE painfully slow even though SpeedTest shows otherwise-imageuploadedbytapatalk1430254695.659664.jpg


    Sent from my  iPhone 6 Plus!
    04-28-2015 04:58 PM
  7. Evilguppy's Avatar
    Following advice I read on imore, I turned on LTE for data only, since I don't care if voice is 3G. Now it's perfect. Browsing is way faster and voice is unaffected.
    Pale Wraith likes this.
    04-29-2015 04:28 PM
  8. Ledsteplin's Avatar
    Following advice I read on imore, I turned on LTE for data only, since I don't care if voice is 3G. Now it's perfect. Browsing is way faster and voice is unaffected.
    Be careful with those Cellular tests. They can use a lot of data.


    Sent from my ancient but trustworthy iPhone 5. ☮
    04-29-2015 04:42 PM
  9. robbrick's Avatar
    Following advice I read on imore, I turned on LTE for data only, since I don't care if voice is 3G. Now it's perfect. Browsing is way faster and voice is unaffected.

    I believe doing this on Verizon (Sprint doesn't yet allow this AFAIK) will not allow simultaneous voice and data as they have recently allowed via iPhone 6/6+. On ATT or T-Mobile, I don't think it would matter. I have T-Mobile and do not have the problem the OP is talking about. My LTE data is way faster than most WiFi I can connect to and more reliable.
    04-29-2015 05:47 PM
  10. Pale Wraith's Avatar
    SpeedTest shows the the pain I experience this time of night. Will be like this until about 10:30-11pm.


    Sent from my iPhone 6 Plus
    04-29-2015 10:52 PM
  11. robbrick's Avatar
    SpeedTest shows the the pain I experience this time of night. Will be like this until about 10:30-11pm. https://images.tapatalk-cdn.com/15/04...bdc245d159.jpg


    Sent from my iPhone 6 Plus
    where is that? Why does it happen this time of the night I wonder...
    04-30-2015 01:15 AM
  12. Pale Wraith's Avatar
    Mesa, AZ (I'm about 15mi east of Phoenix). T-Mobile keeps saying there's no network issues and no work being done in the area. Starts around sunset and continues for a few hours. I'm at that time where it starts getting better.


    Sent from my iPhone 6 Plus
    04-30-2015 02:08 AM
  13. Pale Wraith's Avatar
    So this has been going on today. That's with a VPN connection.


    Sent from my iPhone 6 Plus
    04-30-2015 12:47 PM
  14. Pale Wraith's Avatar
    That was fun while it lasted.


    Sent from my iPhone 6 Plus
    04-30-2015 02:11 PM
  15. Ledsteplin's Avatar
    That was fun while it lasted.


    Sent from my iPhone 6 Plus
    No wifi service?
    Any UFO activity?

    Sent from my ancient but trustworthy iPhone 5. ☮
    05-01-2015 02:12 PM
  16. sectionsix's Avatar
    Strange this is my speed test for last night in Phoenix at the airport before my flight. Wife's phone was the same.


    Sent from my iPhone using Tapatalk
    05-01-2015 02:32 PM
  17. sectionsix's Avatar
    Here is an earlier one.


    Sent from my iPhone using Tapatalk
    05-01-2015 02:34 PM
  18. Le Caid's Avatar
    That's what my public library looks like except the Upload is almost as slow. Wished I knew what they do with my tax dollars!


    Sent from my iPhone 6 Plus using Tapatalk
    05-01-2015 02:55 PM
  19. Ledsteplin's Avatar
    Strange this is my speed test for last night in Phoenix at the airport before my flight. Wife's phone was the same. https://images.tapatalk-cdn.com/15/05...c42f03fe15.jpg


    Sent from my iPhone using Tapatalk
    So what's up with Cellular in the Phoenix area? Have you called your carrier? Reset Network Settings? Strange for sure!


    Sent from my ancient but trustworthy iPhone 5. ☮
    05-01-2015 04:32 PM
  20. Pale Wraith's Avatar
    Following advice I read on imore, I turned on LTE for data only, since I don't care if voice is 3G. Now it's perfect. Browsing is way faster and voice is unaffected.
    This has helped some. Not "OMG it's soooo fast" but a clearly noticeable difference.


    Sent from my iPhone 6 Plus
    05-01-2015 06:24 PM
  21. sectionsix's Avatar
    So what's up with Cellular in the Phoenix area? Have you called your carrier? Reset Network Settings? Strange for sure!


    Sent from my ancient but trustworthy iPhone 5. ☮

    Not sure. Just got back from my cruise to Alaska. Speeds in the metro Phoenix area seem to be fine now. They were just extremely slow the two days before I left for my vacation.


    Sent from my iPhone using Tapatalk
    05-09-2015 07:44 PM
  22. Channan's Avatar
    Be careful with those Cellular tests. They can use a lot of data.


    Sent from my ancient but trustworthy iPhone 5. ☮
    Speed tests using the speedtest.net app on T-Mobile don't count against your data.

    That's also possibly why OP was seeing great speed tests but bad performance.
    05-09-2015 08:42 PM
  23. FaisDogg's Avatar
    LTE painfully slow even though SpeedTest shows otherwise-imageuploadedbytapatalk1433587279.642388.jpg


    Sent from my  iPhone 6 Plus!
    06-06-2015 06:41 AM

Similar Threads

  1. Replies: 3
    Last Post: 01-04-2015, 06:39 PM
  2. Why won't it work even if I have enough storage?
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 01-04-2015, 11:16 AM
  3. LaCie shows both its rugged and fashionable sides with new portable drives
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 01-04-2015, 09:40 AM
  4. Vector 72: Is this the show?
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 01-03-2015, 10:12 PM
  5. Can you show me the date and time some of my contacts were deleted
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 01-03-2015, 02:59 AM
LINK TO POST COPIED TO CLIPBOARD