1. iMore Question's Avatar
    I have an iphone 5s recently I tried updating my phone from ios 8.4 to ios 9.0.2 via itunes on windows pc and I received an error (14)
    and now the phone is stuck in recovery mode.
    When I tried updating again I got the message the firmware is corrupted while downloading.
    My phone is stuck in a recovery loop Please help as soon as possible
    10-16-2015 10:19 PM
  2. Rob Phillips's Avatar
    Welcome to iMore. Error 14 generally relates to an issue with the USB connection to the Mac/PC. If you're stuck in a recovery loop you might try to put the phone into DFU mode to stop it. For instructions on how to enter DFU mode, follow this guide.

    Hope this helps!
    10-16-2015 10:24 PM
  3. EmceeGeek's Avatar
    Turn off firewalls or any blockers. Update your drivers too
    10-17-2015 12:13 AM
  4. Indabaa's Avatar
    According to some users on apple support page you should try checking USB device or use another device. Also clean your restore of iOS version you are trying to install.

    Hope this guide help you.
    06-25-2016 12:15 AM

Similar Threads

  1. Replies: 2
    Last Post: 06-21-2016, 09:31 PM
  2. Replies: 2
    Last Post: 10-16-2015, 10:23 PM
  3. How to connect the Magic Keyboard to your iPad
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 10-16-2015, 10:00 PM
  4. Replies: 1
    Last Post: 10-16-2015, 09:34 PM
  5. Replies: 0
    Last Post: 10-16-2015, 07:40 PM
LINK TO POST COPIED TO CLIPBOARD