1. DucmanVino's Avatar
    This is very annoying to say the least. Always check my email thru my phone after inbox is all read and moved. I still get 2 unread mail when the inbox is actually clear. anyone else getting this error? i.e Icon on the home scree showing 2 ???
    12-31-2013 06:03 PM
  2. rdiddy_25's Avatar
    Maybe they're older emails that haven't been read. On a computer, mark all emails as read, should solve your problem
    12-31-2013 06:08 PM
  3. serglb's Avatar
    How many email accounts do you have on your phone?


    Sent from my Black iPhone 5S using Tapatalk 😊
    12-31-2013 06:10 PM
  4. DucmanVino's Avatar
    Maybe they're older emails that haven't been read. On a computer, mark all emails as read, should solve your problem
    believe, i checked every folders , trash and nothing there
    12-31-2013 06:42 PM
  5. DucmanVino's Avatar
    How many email accounts do you have on your phone?


    Sent from my Black iPhone 5S using Tapatalk
    one
    12-31-2013 06:42 PM
  6. serglb's Avatar
    one
    Hmm, try deleting then re-adding that account (it's not much of a hassle). If that doesn't work mark all messages as read as the other user said above ^ if all else fails then you might want to do a restore *


    Sent from my Black iPhone 5S using Tapatalk 😊
    12-31-2013 06:44 PM
  7. DucmanVino's Avatar
    ok will try that, thanks
    serglb likes this.
    12-31-2013 06:45 PM
  8. nikkisharif's Avatar
    This has happened to me a few times and its extremely annoying! For some reason the unread emails weren't showing up on my phone but when I checked on the computer they were there. I had to delete the account and add it back...haven't had any issues since. Good Luck!!!
    serglb and Wlctttrue like this.
    12-31-2013 10:06 PM
  9. DucmanVino's Avatar
    deleted the account and still experiencing
    12-31-2013 10:12 PM
  10. jonfran21's Avatar
    What's the domain? I have this problem a lot in my Yahoo Mail account. I will read all messages and it says no unread messages but the icon will still show 1-2 unread messages. If I sign onto the website, there is 1-2 or whatever the number is unread messages. It's as if the phone thinks they are read but fails to properly communicate this to the Yahoo mail server. It happened a lot with my Droid as well before I switched.

    Are you using stock mail app or Yahoo mail app or another app?
    Jim Fagan likes this.
    01-01-2014 08:56 PM
  11. Dwood1970's Avatar
    Check to make sure you don't have a message left unread in a thread of messages. I had this problem and that's what it was.
    01-01-2014 10:31 PM
  12. Wlctttrue's Avatar
    I have this problem a lot. I also have yahoo mail account. The only solution is what NikkiSharif has said. I plug it in to the computer to erase it.
    01-01-2014 10:35 PM
  13. shadyace's Avatar
    Hey man same happened with my icloud

    Log on to the account with a PC and the offending mail shall reveal itself


    Sent from my iPhone using Tapatalk
    01-01-2014 11:14 PM
  14. DucmanVino's Avatar
    using yahoo. as I've said it annoys the bejesus out of me
    What's the domain? I have this problem a lot in my Yahoo Mail account. I will read all messages and it says no unread messages but the icon will still show 1-2 unread messages. If I sign onto the website, there is 1-2 or whatever the number is unread messages. It's as if the phone thinks they are read but fails to properly communicate this to the Yahoo mail server. It happened a lot with my Droid as well before I switched.

    Are you using stock mail app or Yahoo mail app or another app?
    01-02-2014 10:22 PM
  15. EmceeGeek's Avatar
    This has been happening to me as well, except mine does it when I go to "edit" and mark all of them as read. It'll show that it's "read" when I go back under edit but the notification number will still be there and there will still be the bubble next to the email as if it's new. I just have to do it twice and it clears.


    Sent from my [Gold] iPhone 5S
    01-02-2014 10:55 PM
  16. samsmith726's Avatar
    Are you still experiencing this issue? I had a similar problem when I would sync my gmail account to my iphone, I would get a large number of unread emails notifications, yet I wouldn't see these unread emails on my phone or on gmail on a computer.

    Solution: went to my gmail account on my computer, went to the menu bar on the left of the screen (reads from top to bottom: Inbox, Starred, Important, etc). When you hover your mouse over 'Inbox', a little drop down menu arrow will appear. I clicked that and selected 'Unread First'. This showed about 80-90 emails that were from years past and unread. Deleted all those emails and the notification went away.

    Sorry if that was long winded, hope it helps!
    01-07-2015 03:25 PM
  17. Thumper423's Avatar
    I have this problem also. Closing the mail program and re-opening it will get rid of the unread mail indicator.
    HickseyGolfer likes this.
    01-16-2015 06:10 PM
  18. tomdooley's Avatar
    Had this issue. Tapped 'Edit', and checked the 'Unread' tab in the mail application. Opened the unread tab and refreshed.
    Done.
    01-30-2015 01:43 PM
  19. Mariam Pera's Avatar
    This worked for me!
    05-19-2015 10:01 AM
  20. deadhead509's Avatar
    none of this has worked for me ! it still says i have 3 unread emails and i have done ALL of thee above things ! getting really frustrated !!
    10-04-2015 12:45 PM
  21. HickseyGolfer's Avatar
    Had this issue on an Enterprise email account on iphone 5s.

    Go to Settings--Mail, Contacts, Calendar---open specific email account-- where it says "Mail" or "Account", switch that to the OFF position.

    I then did a hard reset ...hold both buttons. Once the iphone is back and running, go back to the same place and switch it to the ON position.

    The phantom unread emails should disappear.
    Calum Murdock likes this.
    10-08-2015 06:13 PM
  22. coachrobin's Avatar
    Thanks, Hicksey Golfer! Literally weeks of frustration were resolved tonight thanks to your counsel. You've made my day!
    11-01-2015 02:17 AM
  23. versapak's Avatar
    Had this issue on an Enterprise email account on iphone 5s.

    Go to Settings--Mail, Contacts, Calendar---open specific email account-- where it says "Mail" or "Account", switch that to the OFF position.

    I then did a hard reset ...hold both buttons. Once the iphone is back and running, go back to the same place and switch it to the ON position.

    The phantom unread emails should disappear.
    Excellent! This worked for me. Thank you.

    1st world issue for sure, but it was very annoying to see that one unread email all of the darn time and never being able to find it.
    11-03-2015 06:27 AM
  24. wardhuber's Avatar
    Yes, problem solved. Went into settings, disabled the email setting, hard closed the iPhone then restarted.
    11-17-2015 02:17 PM
  25. Calum Murdock's Avatar
    Had this issue on an Enterprise email account on iphone 5s.

    Go to Settings--Mail, Contacts, Calendar---open specific email account-- where it says "Mail" or "Account", switch that to the OFF position.

    I then did a hard reset ...hold both buttons. Once the iphone is back and running, go back to the same place and switch it to the ON position.

    The phantom unread emails should disappear.
    Thank you so much HickseyGolfer! This actually worked! So happy as this had been bugging me for ages. Kept opening up my Mail thinking I had a new email. Great stuff!
    12-02-2015 02:08 PM
26 12

Similar Threads

  1. Does the iPhone 5S count steps on a treadmill?
    By steve72852 in forum iPhone 5s
    Replies: 3
    Last Post: 12-31-2013, 11:42 PM
  2. Iphone inactivated nag message
    By edyb in forum Ask a Question
    Replies: 1
    Last Post: 12-31-2013, 08:15 PM
  3. Replies: 1
    Last Post: 12-31-2013, 07:44 PM
  4. Replies: 3
    Last Post: 12-31-2013, 07:40 PM
  5. Is the iPad Air Mac-centric?
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 12-31-2013, 01:50 PM
LINK TO POST COPIED TO CLIPBOARD