1. 1337Ralfy69's Avatar
    Hello Guys,

    I`ve bought secondhand Iphone 5.
    On the back cover IMEI and Model nr. does not match. (Wasn`t paying attention when I was buying the phone ) (Logic board changed?)

    I`ve tried everything, restoring, resetting networks, airplane mode on/off, setting date and time manually, updating to 9.3 beta and other methods with no success.
    Sim card is brand new, few days ago I got it, works in another phones.

    The guy from what I bought it said - after updating to 9.2, issue started when it was 8.x.x it worked with no problems.

    I also have to mention - it has 1 large crack in glass(not screen, screen is working fine)
    It looks like the guy tried to change the glass, and that`s why there is a crack, because the UV glue (or maybe other glue that guy used) is not hardened properly.

    I thought - easy fix, change the glass and good to go (glass is on the way from ebay)

    But no, No Service issue is driving me nuts

    What I`ve found to get network to work for short period of time - changing LTE to 3g, after restarting phone service is available for about 20 to 40 seconds(but not always), but what is interesting - if i call somebody in that period of time, I can talk more than 5 minutes, but after hanging up, service goes to - "No Service". And also in that period of time I can send messages(when service is available obviously).
    And in settings>general>about - Always shows Carrier - LMT 23.0(Latvia) (when service is available or not), but Network - Not available(and of course when its available it shows - LMT).

    Update - When phone is set to 3g mode, almost always when I restart it, It is available(Service) about for a minute, then drops signal, and if I switch it to 2g or LTE, it almost instantly drops signal, or when I lock the phone, same thing.

    What I`ve done - reseated antenna connector(with no luck).

    Reheat Gsm related Ic`s?
    Power amplifier IC?
    Cap`s or coils bad?
    Software issue? (Before I was 100% sure of that, but now I`m not)

    Your help will be very appreciated.
    Thanks
    02-20-2016 10:46 PM
  2. Rob Phillips's Avatar
    Welcome to iMore! There are so many things that could be wrong here. It sounds like this entire phone has been pieced together.
    Have you tried contacting your carrier to make sure there isn't a problem on their end?
    Perhaps someone with more experience with iPhone internals will have a better idea. To me, it sounds like you're fighting an uphill battle.
    drummerjb and 1337Ralfy69 like this.
    02-20-2016 10:51 PM
  3. drummerjb's Avatar
    Hello, welcome to iMore! As a former FRS (iOS Tech), they always taught us to look at the issue like a pie so-to-speak. To consider hardware or software, as well as environmental. Based on what you've said, it does sound like it could quite possibly be hardware. I commend you for giving it the shot you have thus far. You know for sure that your SIM is known to be good, and proven that because of it working on any other phone you've tested it with.
    I hope this somewhat helps, but I'm afraid if the person before you may have attempted to "fix" it, the phone may not work properly if something could have been damaged. I know it sounds almost like BS, but static electricity CAN and will actually blow microscopic holes into parts of the board if precautions aren't taken.
    1337Ralfy69 likes this.
    02-20-2016 11:08 PM
  4. 1337Ralfy69's Avatar
    Thank you, DevilishBanker, for warm welcoming
    It not only sounds like it is pieced together, but it looks like too, some screws are missing.
    I don`t think it`s carriers fault, because same Sim card works in another phones.
    Yeah, I know, but I want to win the battle, I just like fixing stuff
    Rob Phillips likes this.
    02-20-2016 11:11 PM
  5. Rob Phillips's Avatar
    Hello, welcome to iMore! As a former FRS (iOS Tech), they always taught us to look at the issue like a pie so-to-speak. To consider hardware or software, as well as environmental. Based on what you've said, it does sound like it could quite possibly be hardware. I commend you for giving it the shot you have thus far. You know for sure that your SIM is known to be good, and proven that because of it working on any other phone you've tested it with.
    I hope this somewhat helps, but I'm afraid if the person before you may have attempted to "fix" it, the phone may not work properly if something could have been damaged. I know it sounds almost like BS, but static electricity CAN and will actually blow microscopic holes into parts of the board if precautions aren't taken.
    Welcome to iMore! Please stick around. We can always use members with in-depth hardware backgrounds!
    02-20-2016 11:42 PM
  6. Manoj Sugandh's Avatar
    As per you phone seems a refurbished one and must be fallen one
    Sometimes network and then no service means
    Fault related with tx section or antenna switch
    First check some components for broken
    check by manual search networks available
    Rehot or replace 2g or 3G p.a as per missing network during manual search when there is network
    02-28-2016 11:48 AM

Similar Threads

  1. Zedge for Iphone
    By Bovetek in forum iPhone 6s
    Replies: 38
    Last Post: 10-22-2016, 04:14 PM
  2. iPhone 5s 3D Touch?
    By Gloria Barros1 in forum Ask a Question
    Replies: 1
    Last Post: 02-20-2016, 02:46 PM
  3. How do I connect my pendrive to my iPhone 5s?
    By iMore Question in forum iPhone 5s
    Replies: 1
    Last Post: 02-20-2016, 11:44 AM
  4. iPhone not turning on nor connecting to iTunes nor charging !
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 02-20-2016, 11:33 AM
  5. my iphone is stuck on upgrading icloud settings
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 02-20-2016, 10:04 AM
LINK TO POST COPIED TO CLIPBOARD