1. iMore Question's Avatar
    I'm not receiving texts from other iphones. My iMessage selection in Setup is greyed out and unselectable.

    I have an iPhone 5
    10-29-2015 02:15 PM
  2. eyecrispy's Avatar
    Try this:
    Settings / Messages / Send & Receive.
    Uncheck each email address to remove it
    Go back one screen and turn iMessage off
    Go back again and select FactTime and unselect all the emails and then turn FactTime off.
    Wait about 5 min
    Turn iMessage and FaceTime back on with no email addresses selected (it should just have your phone number checked).

    Let me know if that works.
    10-29-2015 02:25 PM

Similar Threads

  1. Notifications stuck half way down iPhone, how can I restart my phone?
    By iMore Question in forum General Apple News & Discussion
    Replies: 1
    Last Post: 10-30-2015, 07:03 PM
  2. How do you turn off auto rotation?
    By iMore Question in forum General Apple News & Discussion
    Replies: 3
    Last Post: 10-30-2015, 07:00 PM
  3. Can I get an online gift card resent?
    By iMore Question in forum General Apple News & Discussion
    Replies: 3
    Last Post: 10-29-2015, 05:43 PM
  4. How can I get my Whatsapp back to how it was?
    By iMore Question in forum WhatsApp
    Replies: 1
    Last Post: 10-29-2015, 02:41 PM
  5. DSCO is a new GIF app from the makers of VSCO Cam
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 10-29-2015, 01:12 PM
LINK TO POST COPIED TO CLIPBOARD