1. anitaib's Avatar
    Hi, my iPhone got crazy - it keeps filling up my inbox up to 500 old emails - I deleted 50 or a 100 and it fill it up again (up to 500) with the newest + old emails = Help!!!! - what do I do? is there anything that I can do? that can be done?
    Thanks
    Anita
    03-26-2015 12:46 PM
  2. Just_Me_D's Avatar
    Login to your email provider's website and delete the email messages you want to delete. Make sure they are removed from the trash/delete mail folders as well. The results should sync to your iPhone.
    anitaib likes this.
    03-26-2015 12:49 PM
  3. anitaib's Avatar
    THANK YOU Just_Me!!!! (-:
    I did what you've recommended and my phone is "normal" again.
    it's so easy when you know what to do.... (-:
    03-26-2015 01:52 PM
  4. Just_Me_D's Avatar
    THANK YOU Just_Me!!!! (-:
    I did what you've recommended and my phone is "normal" again.
    it's so easy when you know what to do.... (-:
    You're very welcome...
    03-26-2015 02:12 PM
  5. angelfish03's Avatar
    I've done this and it still isn't working on my phone. It's making me crazy! I've deleted the account and restarted my phone and then re-added the account, but all of the messages are still there.
    05-28-2015 03:39 PM
  6. xtremeled's Avatar
    I've done this and it still isn't working on my phone. It's making me crazy! I've deleted the account and restarted my phone and then re-added the account, but all of the messages are still there.
    If the messages are on the server, when you delete and then add the account it takes all the emails on the server and syncs them to your phone. You need to remove them from the server. There might be a setting to leave a copy on the server. Uncheck this option if you have it
    05-28-2015 03:55 PM
  7. Ledsteplin's Avatar
    Fortunately, I never have any come back to my inbox. But they do come back to the Junk folder in my Gmail account. So I just log in to my Gmail account in Safari and delete them there. That works. It's odd that some come back and others don't.


    ☮
    05-28-2015 07:17 PM
  8. AUKunchurkar's Avatar
    That was the same case with Mine.. I had so many mails which kept coming.

    The solution to it is very simple.

    Make a separate folder (Maybe: Moved Inbox Mails) in the original server i.e. Gmail/Yahoomail/Hotmail/ Any other domain and move all your mail from your Inbox to this folder.

    You can just keep may be 3 days emails in the Inbox folder and thats it!!!.

    and voila -- Problem fixed.

    This worked very well of Iphone 6s - iOS 9.1
    11-23-2015 07:01 AM
  9. James Carroll's Avatar
    I delete my mail on my Samsung Android tablet and it keeps coming back what can I do ?
    02-17-2016 09:53 AM
  10. Joshua Evans4's Avatar
    Login to your email provider's website and delete the email messages you want to delete. Make sure they are removed from the trash/delete mail folders as well. The results should sync to your iPhone.
    But why should we even have to do that? It's just another glitch that waste everyone's time.
    06-30-2016 01:50 AM
  11. poeaeewe's Avatar
    If you want to delete emails forever from your iPhone, you can use iPhone data eraser, which can help you erase data from iPhone with zero opportunity for restoring.
    07-01-2016 04:41 AM
  12. Ledsteplin's Avatar
    But why should we even have to do that? It's just another glitch that waste everyone's time.
    Keep in mind these are tiny computers and are not perfect. All computers have glitches. Try going to your computer and delete those emails on your account there.
    Also try going to Settings, Mail, Contacts and Calendar > your email account> sign out. Then sign back in.
    07-01-2016 07:00 AM
  13. scruffypig's Avatar
    But why should we even have to do that? It's just another glitch that waste everyone's time.
    It depends on the email protocol your email is set up as. It is not a glitch.
    07-03-2016 05:54 PM
  14. JFairweather's Avatar
    This is not a bug with the phone but with the providers, who are not prepared to deal with a problem that is massive and which requires a reworking of standards.

    If your email is set up as an IMAP account, if you delete an email from any device, it removes it from the server. If your email is set up as a POP account, deleting a message only deletes it locally. This works great through an email client on your computer, but with smartphones, which access mail servers in a different way, the server is not understanding that the email on your phone has been read and deleted. It stupidly thinks it was never sent to your phone, so it dutifully sends it again.

    I prefer POP because there are a lot of email messages that I want to keep on my computer but not on my phone. A ehile back I followed a procedure on my iPhone that successfully sorted this problem out but I managed to forget how I did it.

    In a separate issue, I ended up having trouble using AT&T's outbound server so I did what used to work properly – I deleted the email account from my phone, along with the server presets, then added the email account back. Somehow I managed to lose a magic setting and I'm back to dealing with a couple hundred messages that keep redownloading.

    If I stumble across the fix, I'll post it here. One thing I will do (and others can check this out as well) is to access my email account via a web browser and see if there is a setting there that will take care of the downloading issue.

    In the meantime, the only way I know is to switch your email to an IMAP account and being careful about which messages you delete, and moving messages you want to save into a separate folder.
    07-06-2017 11:02 AM

Similar Threads

  1. On the fence about keeping 15" Retina macbook pro
    By clayton006 in forum MacBook Pro
    Replies: 5
    Last Post: 03-25-2015, 09:44 PM
  2. Replies: 0
    Last Post: 03-25-2015, 04:51 PM
  3. No Apple Watch mixing-and-matching come April 10 collections are it
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 03-25-2015, 02:12 PM
  4. A look back at Apple's last 12-inch laptop
    By iMore.com in forum iMore.com News Discussion
    Replies: 0
    Last Post: 03-25-2015, 12:12 PM
  5. Replies: 1
    Last Post: 03-25-2015, 11:17 AM
LINK TO POST COPIED TO CLIPBOARD