1. kusalanupama's Avatar
    after turning off the display of my iPhone and after keeping it aside for 10 or 15 minutes if automatically turn off the WIFI. when i turn on the display then it again shows after like 2 or 3 seconds, then only delivers my messages and mail.
    please help, what should i do.
    im on iOS 6.1.4
    06-23-2013 06:05 AM
  2. Laelipoo's Avatar
    Nothing.


    This is normal and expected behavior. Wifi is only persistent when your device is plugged in.
    Fausty82 likes this.
    06-23-2013 08:19 AM
  3. Just_Me_D's Avatar
    Have you tried rebooting your iPhone? If not, give it a try. You can also try going to Settings-General-Reset and then select "Reset Network Settings". Let us know if either helped or not. In the meantime, have a great weekend....
    kusalanupama likes this.
    06-23-2013 08:19 AM
  4. Chris Kerrigan's Avatar
    Unless I'm mistaken, this is normal behavior. Happens to me as well. WiFi "sleeps" when the screen shuts off, with an exception being made for when it's plugged in.

    after turning off the display of my iPhone and after keeping it aside for 10 or 15 minutes if automatically turn off the WIFI. when i turn on the display then it again shows after like 2 or 3 seconds, then only delivers my messages and mail.
    please help, what should i do.
    im on iOS 6.1.4
    kusalanupama likes this.
    06-23-2013 09:33 AM
  5. kch50428's Avatar
    It's not so much 'sleep' - it's more like a "hot standby"...
    06-23-2013 09:37 AM
  6. Just_Me_D's Avatar
    I'm missing something here. The OP is stating that he or she is not receiving any messages or emails (I assume he or she is referring to notifications) until after he or she wakes the device when connected to Wi-Fi. If that's the case, that shouldn't be occurring.
    kusalanupama likes this.
    06-23-2013 09:54 AM
  7. kusalanupama's Avatar
    i mean on whatsapp, after a while the message is sent by my friend i get the it when i turn on the display. which i really need to reply back as soon as he message me.
    06-23-2013 10:14 AM
  8. Laelipoo's Avatar
    I was talking about the wifi turning off--that is normal. As for why your messages are getting delayed, perhaps your network 3G is a little spotty.
    kusalanupama likes this.
    06-23-2013 10:15 AM
  9. kusalanupama's Avatar
    okay then if its a normal thing canno help it right.
    thanks for everyone for your support
    06-23-2013 10:20 AM
  10. Chris Kerrigan's Avatar
    It's not so much 'sleep' - it's more like a "hot standby"...
    Thanks for the clarification!
    06-23-2013 10:30 AM
  11. Just_Me_D's Avatar
    okay then if its a normal thing canno help it right.
    thanks for everyone for your support
    It is normal for your Wi-Fi to disengage, but it is not normal for you to not receive text messages and email messages during that time.
    kusalanupama likes this.
    06-23-2013 10:33 AM
  12. Laelipoo's Avatar
    Where I used to live we got 1-2 bars, and that was with an external antenna. We missed calls, had crappy battery life, all due to the lack of reception. The wifi was the only thing that worked. Now I live in perfect reception and don't have the problems I used to, which is what I think could be happening to the OP.
    Just_Me_D likes this.
    06-23-2013 10:35 AM
  13. Vvreddy's Avatar
    Unless I'm mistaken, this is normal behavior. Happens to me as well. WiFi "sleeps" when the screen shuts off, with an exception being made for when it's plugged in.
    09-30-2013 12:49 AM
  14. Vvreddy's Avatar
    Seems issue with device or s/w.when playing some video from YouTube for long time (without touching or pressing any button on iPhone ) in full screen mode sometimes it using 4g data even wifi is available..so it unnecessarily wasting my data plan..hope there will be some fix for this ..
    09-30-2013 12:59 AM

Similar Threads

  1. Wifi keeps disconnecting
    By freyaheart in forum Original iPad
    Replies: 9
    Last Post: 09-11-2010, 01:57 PM
  2. Can you get a discount off an iphone if you add a line later?
    By Noriega7333 in forum Carrier Discussion Lounge
    Replies: 2
    Last Post: 08-06-2010, 09:08 AM
  3. having trouble getting 720P movies off my iphone
    By sepehrsh in forum iPhone 4
    Replies: 3
    Last Post: 07-05-2010, 09:38 PM
  4. my 3gs gets crazy when i use the power charger
    By zonico3000 in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 9
    Last Post: 02-12-2010, 07:12 AM
  5. WIFI won't shut off?
    By eaterofdog in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 4
    Last Post: 11-13-2009, 04:39 PM
LINK TO POST COPIED TO CLIPBOARD