1. Dixon Cox's Avatar
    I noticed that only few wireless networks have an option to reconnect automatically (without asking). My work network doesn't even have an option for auto-reconnect. I downloaded a tweak called "Insomnia" that keeps internet-connected programs connected and running in the background, but I wonder if there is a tweak to get the phone to simply auto-connect to approved wireless networks when in range.

    Any suggestions?
    03-05-2013 02:16 PM
  2. kch50428's Avatar
    The iPhone does this all by itself - stock. No tweaking needed.

    If you have to log on each time you connect, that's the wifi hotspot owner's security measures... not the fault of the phone.
    John Yester likes this.
    03-05-2013 02:31 PM
  3. Dixon Cox's Avatar
    No, it does not!!! At least not the iPhone 5. It has this option for some networks, not for most. A local supermarket requires login, so that opens automatically, because the settings allow to auto-connect to that particular network. As I mentioned in the OP, my work network (which doesn't require login) doesn't even show the option of auto-connecting. If I go to settings->wifi->tap on network, then it connects, but wouldn't do it automatically.

    Hence the original question.

    The iPhone does this all by itself - stock. No tweaking needed.

    If you have to log on each time you connect, that's the wifi hotspot owner's security measures... not the fault of the phone.
    03-05-2013 04:01 PM
  4. Skilarchi's Avatar
    Clever pin but its not free
    03-05-2013 04:12 PM
  5. Highrisedrifter's Avatar
    No, it does not!!! At least not the iPhone 5. It has this option for some networks, not for most. A local supermarket requires login, so that opens automatically, because the settings allow to auto-connect to that particular network. As I mentioned in the OP, my work network (which doesn't require login) doesn't even show the option of auto-connecting. If I go to settings->wifi->tap on network, then it connects, but wouldn't do it automatically.

    Hence the original question.
    Actually it does. The out-of-the-box default option for the phone is that it will remember the settings and automatically reconnect to a wifi hotspot that you have properly connected to at least once before once you are in range of said hotspot.

    This isn't an opinion, this is just what the phone does. If your phone doesn't do this then that issue is peculiar to either your device or the wifi hotspot, not all iPhones, which follow the protocol above.
    kch50428 likes this.
    03-05-2013 04:33 PM
  6. Just_Me_D's Avatar
    No, it does not!!! At least not the iPhone 5. It has this option for some networks, not for most. A local supermarket requires login, so that opens automatically, because the settings allow to auto-connect to that particular network. As I mentioned in the OP, my work network (which doesn't require login) doesn't even show the option of auto-connecting. If I go to settings->wifi->tap on network, then it connects, but wouldn't do it automatically.

    Hence the original question.
    Kch50428 did indeed give you the correct answer. Do this with your iPhone 5: Go to Settings - Wi-Fi and then scroll to the bottom of the screen. There is an option to "Ask to Join Networks". If it is OFF, your will NOT be prompted to join a network unless it is a 'NEW' network as in one you've never connected to before. The wording underneath the option is crystal clear. Exceptions will be as Keith stated above when he mentioned Wi-Fi Hotspot owners' security measures.
    03-05-2013 04:34 PM
  7. Dixon Cox's Avatar
    Kch50428 did indeed give you the correct answer. Do this with your iPhone 5: Go to Settings - Wi-Fi and then scroll to the bottom of the screen. There is an option to "Ask to Join Networks". If it is OFF, your will NOT be prompted to join a network unless it is a 'NEW' network as in one you've never connected to before. The wording underneath the option is crystal clear. Exceptions will be as Keith stated above when he mentioned Wi-Fi Hotspot owners' security measures.
    I really hate to repeat myself, but the reason for my question is that this doesn't work. My "Ask to Join Networks" is set to OFF. My home wifi connects automatically because I set auto-join to ON for that particular network. Still, some networks, e.g. my work, don't have the option to auto-join. This has nothing to do with my phone, it can only be a network setting.

    Again, as stated in the OP, I'm trying to find out if there is a tweak to enable auto-join on all networks.
    03-06-2013 08:41 AM
  8. Dixon Cox's Avatar
    Clever pin but its not free
    Thanks! I'll look around for some freebies, but if there aren't any, I'll give that a try. It's just $2 as it is, so not a big deal.
    03-06-2013 08:43 AM
  9. Dixon Cox's Avatar
    Attaching screencap of settings for that particular network. As you can see, no auto-join option there.
    Attached Thumbnails Tweaks to get wifi to auto-connect when in range?-iphone_networkscreen.jpg  
    03-06-2013 08:53 AM
  10. Highrisedrifter's Avatar
    I really hate to repeat myself, but the reason for my question is that this doesn't work. My "Ask to Join Networks" is set to OFF. My home wifi connects automatically because I set auto-join to ON for that particular network. Still, some networks, e.g. my work, don't have the option to auto-join. This has nothing to do with my phone, it can only be a network setting.

    Again, as stated in the OP, I'm trying to find out if there is a tweak to enable auto-join on all networks.
    Right, on the off chance that were all at crossed wires here, let me try something else.

    At the very top of the settings screen for an individual network, there should be a button that says "Forget This Network." If this does not appear then the wifi hasn't remembered the password for that network, even if you are currently connected to it, meaning you will need to tap in the password again when you leave and return to the wifi area. I had this issue myself on my iPhone 5 and the way I resolved it was to make sure the network was forgotten, then manually type in the name of the network into the 'Other' box exactly as it appears on the screen, including caps etc. Choose the correct encryption, tap in the passcode and try that. You might find that the "Forget this network" button now appears and the phone has remembered the network for future use. If this is your issue, this has been reported before, including by me.

    By the way, Cleverpin is a great tweak that means that whilst you are in range of a trusted wifi network (as input by you into the app), your lockscreen passcode will be disabled allowing you to just open your phone without having to type in your code. It doesn't do what you want above.
    Dixon Cox likes this.
    03-06-2013 09:22 AM
  11. Dixon Cox's Avatar
    Highrisedrifter,
    I tried what you suggested with no luck. One thing I noticed doing that is that the network is marked as an enterprise network, as opposed to my home network and other that are just plain WPA2. At this point I suspect that crApple may have disabled the auto-join for these.

    By the way, Cleverpin is a great tweak that means that whilst you are in range of a trusted wifi network (as input by you into the app), your lockscreen passcode will be disabled allowing you to just open your phone without having to type in your code. It doesn't do what you want above.
    Thanks for the heads up. I looked it up and wasn't sure about it from the description. Good to know.
    03-06-2013 09:48 AM
  12. kch50428's Avatar
    At this point I suspect that crApple may have disabled the auto-join for these.
    That's not an Apple problem. It is a security requirement of the wifi node. Auto-join CAN BE and often is DISABLED by the owner of the wifi node and network.
    John Yester likes this.
    03-06-2013 09:59 AM
  13. Dixon Cox's Avatar
    That's not an Apple problem. It is a security requirement of the wifi node. Auto-join CAN BE and often is DISABLED by the owner of the wifi node and network.
    A laughable excuse. My laptop auto-connects, a.k.a. "auto-joins" just fine. No reason for the iPhone to not give me the option to do the same.
    03-06-2013 10:25 AM
  14. Highrisedrifter's Avatar
    At this point I suspect that crApple may have disabled the auto-join for these..
    That's not an Apple problem. It is a security requirement of the wifi node. Auto-join CAN BE and often is DISABLED by the owner of the wifi node and network.
    A laughable excuse. My laptop auto-connects, a.k.a. "auto-joins" just fine. No reason for the iPhone to not give me the option to do the same.
    Sorry Dixon, he's right. Apple don't do this at all as default option to user phones. However, If your phone is a work phone locked by a SysAdmin using the Enterprise tools, then this could happen. If it isn't, it's the decision of the wifi network admin themselves.
    Ledsteplin likes this.
    03-06-2013 10:36 AM
  15. kch50428's Avatar
    A laughable excuse. My laptop auto-connects, a.k.a. "auto-joins" just fine. No reason for the iPhone to not give me the option to do the same.
    There are plenty of reasons which, if explained to you would continue to fall on deaf ears.

    "Your" laptop likely has additional enterprise security measures in place, installed to meet the enterprise's IT security requirements... the laptop is owned by your employer right? Is your phone a company owned phone? If yes, the phone can be managed by company IT security policy as noted above. If no - the network is managed by IT security policies that prohibit auto-joining.
    03-06-2013 10:38 AM
  16. Dixon Cox's Avatar
    There are plenty of reasons which, if explained to you would continue to fall on deaf ears.

    "Your" laptop likely has additional enterprise security measures in place, installed to meet the enterprise's IT security requirements... the laptop is owned by your employer right? Is your phone a company owned phone? If yes, the phone can be managed by company IT security policy as noted above. If no - the network is managed by IT security policies that prohibit auto-joining.
    No. My personal laptop running Windows 7 Pro.
    03-06-2013 10:50 AM
  17. kch50428's Avatar
    No. My personal laptop running Windows 7 Pro.
    ...operating under security measures imposed by Enterprise IT security policy controlled by your employer.
    CDG likes this.
    03-06-2013 10:53 AM
  18. CDG's Avatar
    ...operating under security measures imposed by Enterprise IT security policy controlled by your employer.
    Absolutely the same situation in my case. My personal iPad connects automatically and does operate under additional security measures, a complex password requirement being one of them.

    My iPhone however is not setup to connect to work and needs to log in to wifi every time. In fact iirc, it also times out after a period of inactivity.

    I would think this is pretty normal for Enterprise customers. 😊




    Sent From My Mobile Device Using Tapatalk
    03-06-2013 11:00 AM
  19. Dixon Cox's Avatar
    ...operating under security measures imposed by Enterprise IT security policy controlled by your employer.
    No. Just plain connected to network, entered my UID/PW when prompted, and that's it. With the iPhone (my personal phone, not one from work), I had to enter UID/PW once--I don't have to reenter it, but I do have to manually tap on it to connect every time.

    As stated in my OP, I'd like to find a tweak that would make it unnecessary for me to go to Settings->wifi and tap on my work network any time I'm in range--fairly simple and straight-forward question, IMHO.
    03-06-2013 11:06 AM
  20. kch50428's Avatar
    No. Just plain connected to network, entered my UID/PW when prompted, and that's it.
    It may not be obvious to you... the security is there.
    03-06-2013 11:11 AM
  21. Dixon Cox's Avatar
    It may not be obvious to you... the security is there.
    Which is besides the point.
    03-06-2013 11:19 AM
  22. kch50428's Avatar
    Since you don't like the answers I'm giving, I'll stop trying to explain anything to you...
    03-06-2013 11:26 AM
  23. Highrisedrifter's Avatar
    As stated in my OP, I'd like to find a tweak that would make it unnecessary for me to go to Settings->wifi and tap on my work network any time I'm in range--fairly simple and straight-forward question, IMHO.
    There are no tweaks that do this because iOS does this natively. If your phone does not do that, it is either an issue with your phone or the network you are trying to connect to; it is NOT a wider issue with iOS or iPhones in general.

    There you go, a straightforward answer to a straightforward question.

    If you don't like this answer, I would humbly suggest you do your own research as kch50428 is one of the most knowledgeable people on here, and trust me, he knows more about iOS than you or I do.
    03-06-2013 11:33 AM
  24. Dixon Cox's Avatar
    There are no tweaks that do this
    ok.

    because iOS does this natively.
    As I described (and demonstrated with a screen cap!) it doesn't. So it's not me not liking the answers. It is answers not addressing the issue and instead telling me that Apple knows best.

    If your phone does not do that, it is either an issue with your phone or the network you are trying to connect to;
    Again, nonsense. If my phone didn't auto-connect to any network, then blaming the phone would've been plausible explanation. If no device could auto-connect to my work network, then blaming network would've been a plausible explanation. But when Android phones and Windows computers auto-connect just fine, and the iphones/ipads don't, it is either Apple's fault, or Apple's control issue (again crApple's fault!), which requires a tweak. If there isn't one, then there isn't one. That's fine. But don't treat me like I'm a moron or tell me that the issue doesn't exist because I happened to bring this up first.

    If you don't like this answer, I would humbly suggest you do your own research as kch50428 is one of the most knowledgeable people on here, and trust me, he knows more about iOS than you or I do.
    I'm sure that he knows alot more about iOS than I do, LOL. I wish I known nothing of it -- this is my first and last iPhone, and I have to say, it is the biggest disappointment ever as far as tech purchases go. I really regret I bought into the hype.
    03-06-2013 12:13 PM
  25. John Yester's Avatar
    You can take it back or sell it out right.... But explanations have been stated on why and what works, etc...

    Don't think there is much else to say.....
    kch50428 likes this.
    03-06-2013 12:21 PM
30 12

Similar Threads

  1. How to get the carrier name back when using LS Climacon?
    By ClapToBase in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 10
    Last Post: 02-19-2013, 10:16 PM
  2. Anyone able to get WiFi working with MyWi?
    By reyxlp in forum iPhone 4
    Replies: 5
    Last Post: 02-17-2011, 02:55 PM
  3. Any way to get 4.2.1 on when you have the ipad baseband?
    By entronp in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 17
    Last Post: 12-12-2010, 12:01 AM
  4. Unable to get Touch to work in UITextView
    By sicga in forum The Developer's Lounge
    Replies: 1
    Last Post: 01-20-2010, 08:57 PM
  5. already jb-how to get wifi
    By mixthis in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 1
    Last Post: 03-27-2009, 12:22 PM
LINK TO POST COPIED TO CLIPBOARD