1. buzzshipman's Avatar
    I have an iPhone 5 and have a weird issue. I have AT&T and have a great signal everywhere I go and don't have an issue except when I'm at work at one area. We have a warehouse that is a metal pole barn and you don't get a cell signal in there. We have wifi set up in the warehouse and whenever I go to the warehouse and then leave I never have a data connection and when I do it is only edge. We have other areas of work that have wifi and when I leave those areas the signal is fine because I never lose the data or cell signal. Only in the warehouse. If I restart the phone it corrects the problem. I have even tried turning off the data connection in the settings and when I leave and turn it back on it goes to edge anyway. This is really annoying and if anyone has any ideas that would be a great help.

    Thanks,
    Kevin
    02-13-2013 06:56 AM
  2. SeanHRCC's Avatar
    Have you tried resetting your network settings? This has a good track record of fixing these kinds of wonky issues most times...just go into your settings, go to "general" and scroll down to "reset", select the network settings reset (but make sure you have applicable network passwords ready for when it boots back up). If this doesn't fix the issue, I would definitely get in touch with Apple and see about getting a replacement handset as this is not a very common problem that i have ever seen with the iPhone.
    02-13-2013 07:10 AM
  3. sting7k's Avatar
    I have an iPhone 5 and have a weird issue. I have AT&T and have a great signal everywhere I go and don't have an issue except when I'm at work at one area. We have a warehouse that is a metal pole barn and you don't get a cell signal in there. We have wifi set up in the warehouse and whenever I go to the warehouse and then leave I never have a data connection and when I do it is only edge. We have other areas of work that have wifi and when I leave those areas the signal is fine because I never lose the data or cell signal. Only in the warehouse. If I restart the phone it corrects the problem. I have even tried turning off the data connection in the settings and when I leave and turn it back on it goes to edge anyway. This is really annoying and if anyone has any ideas that would be a great help.

    Thanks,
    Kevin
    What is your 4G signal like outside the warehouse?

    My iPhone 5 behaves in a similar manner. However I'm thinking/finding that iOS 6.x greatly favors a the slower network with better signal than the faster network with even 2-3 bars. What you describe happens at my work as well and some times home in certain areas of the house. It will fall to EDGE and stay there, not very good 4G signal inside at work. Eventually it will jump back up. If I switch to air plane mode it will go back to 4G every time if it's sitting on EDGE.

    Two weeks ago at a super bowl party two of my friends and I have iPhone 5's. They live in an LTE area also with great 4G signal. In side their apartment all 3 of our phones would get 1-3 bars of LTE and then fall to 4G with full bars. The phones would remain there for awhile and sometimes go back to LTE and sometimes not. I actually watched all 3 of them do this and they were all doing at the same times roughly as well. On another note; another friend's GS3 couldn't get LTE signal at all in the apartment.

    So I think you might be seeing normal behavior for iOS 6. I was ready to exchange mine as well since I saw it dropping to EDGE all the time inside work but then when I leave it is reluctant to jump back to 4G.

    Really your only options are to restore as new. If that doesn't help you could get it exchanged at Apple. But you may see the same type of behavior. Does anyone else at your work have this issue with an iPhone 5?
    02-13-2013 10:17 AM
  4. kch50428's Avatar
    Cell phones generally will lock on, and try to hold the strongest signal native to the provider's network - determined by the provider's PRL.
    02-13-2013 10:21 AM
  5. sting7k's Avatar
    Cell phones generally will lock on, and try to hold the strongest signal native to the provider's network - determined by the provider's PRL.
    Anyone have an iPhone 4S with iOS 6 that exhibits this behavior? I never installed iOS 6 on my 4 so I don't know if it's the OS or the hardware really. I'm still waiting on the SIM adapter for my Nexus 4. But none of my previous iPhones or Galaxy Nexus had this behavior. The iPhones always clung to 1 bar of 3G no matter what. My Galaxy Nexus fell to EDGE all the time but always jumped back to 4G right away.
    02-13-2013 10:37 AM
  6. Massie's Avatar
    I get this once in a while—much less since my area got LTE—and toggling airplane mode on and off always fixed it when I didn't want to wait for the signal to register again.
    02-13-2013 03:02 PM

Similar Threads

  1. Jailbroken IPHONE 3Gs 3.1.3 STUCK on apple logo - How to Restore WITHOUT losing data?
    By PlsHelpMe in forum Jailbreaking, Unlocking, Hacks, Themes & Mods
    Replies: 3
    Last Post: 07-01-2012, 07:20 PM
  2. Data usage when on wifi
    By johnkey in forum iPhone 4
    Replies: 6
    Last Post: 06-21-2012, 10:31 AM
  3. Replies: 13
    Last Post: 01-15-2012, 10:46 PM
  4. Replies: 1
    Last Post: 07-26-2011, 07:57 AM
  5. Fix for incorrect data plan after upgrade on Att
    By mg48 in forum Carrier Discussion Lounge
    Replies: 0
    Last Post: 06-18-2009, 10:49 PM
LINK TO POST COPIED TO CLIPBOARD