1. Just_Me_D's Avatar
    Yes I do know that, I'm just saying (BLUE iMessage is only apple devices to apple devices)Attachment 28280

    Okay, but being that you didn't quote the specific post you were replying to, there was no way for me to know that. Anyway, thanks for clarifying...
    03-12-2013 12:30 PM
  2. Chase Isley's Avatar
    Haven't seen this issue yet. Thanks for the answer on how to fix it peeps.
    03-13-2013 12:04 PM
  3. zeteo's Avatar
    I used to own an iphone 3gs, then i switched to android. I never got my friend's text messages because thy were being sent as imessage. The easiest way to fix this is to go to your contacts on your I phone, and select the ex-iPhone number. Then change the label from whatever it used to be to "home" or something you want. Then try to send a message to the DROID phone. It should work, and, if it still does not work after you switch the label back: delete that contact and make a new one (make sure the label is "mobile" and not "iPhone"). hope this helps.
    This is what we have done for those poor folk using android.
    03-14-2013 11:48 PM
  4. anon(52425)'s Avatar
    My wife retired her iphone 4 and bought a Samsung galaxy S3 yesterday. Now I cant text her without turning off iMessage because my phone is a moron and thinks she still has an iphone. I deleted her contact and added her as a new person and put the number as "other" instead of "iphone. This is getting annoying as the rest of my family has iphones and limited text plans as I do and I have to turn off iMessage to talk to my wife then turn it back on to talk with dad and family.

    Any ideas would be greatly helpful, thanks!!
    This happened to me and my GF too. It took roughly 5 days for her phone number to "drop off" from Apple as an iMessage affiliation.
    03-15-2013 01:22 PM
  5. riverlee74's Avatar
    I'm going thru the same thing trying to send my daughter texts she is not getting them because she is a teen! And switches from her iPhone 4S 64GB to her blackberry every other week or so... I have to turn off the iMessage to message my daughter then put it back on to text others, it's VERY ANNOYING I really hope someone can figure this out... I know how you feel I'm looking into it.. Turned he iMessage off.. On her iPhone, still doesn't work, deleted email, didn't work... Reboot hard reboot twice, nothing.. Driving me crazy too.. If anyone can help us would be greatly appreciated! Thank you so much
    04-24-2013 05:30 PM
  6. natasftw's Avatar
    Did you read the thread?

    They posted both a link to remove the phone from her Apple ID so it will no longer be looking for those iMessages and told you how to tap and hold the text to change it to a text message.

    None of what you listed included the steps offered in the thread.
    04-25-2013 12:39 AM
  7. David Saint Hubbins's Avatar
    The answer to this for me (and if you overlooked one of these things, it may work for you) was to go the Apple site and "deregister" my iPhone5. While I was at it, I deregistered all six of the previous iPhones that were still registered there.

    But if you also have an iPad, and if that iPad includes your former iPhone's cellular number as one of its acceptable paths for iMessage, then that is a problem you absolutely must fix. Get the phone number out of the iPad by simply unchecking it in Settings. Otherwise, Apple's server will see a valid device out there and continue delivering messages as iMessages - no regular SMS will be sent.
    05-20-2013 03:00 PM
  8. Arelunde's Avatar
    Once it sends blue just gently hold down the message and send it as a text. It'll eventually recognize you're not in iMessage.
    This works - once you write the message (it still shows blue for iMessage) and send, quickly touch and hold the message area until it asks if you want to send it as a regular text message. After a while - and it may be a couple months - it will automatically send as a text message.

    Does your wife have an iPad? If so, she may find all your iMessages going there via her email @me or @iCloud address. It might help to delete these from her contact listing on your phone if she isn't using them. Also, while there, make sure the label for her phone number is NOT "iPhone."
    Last edited by Arelunde; 05-31-2013 at 05:06 PM.
    05-31-2013 04:49 PM
  9. estroh's Avatar
    In contacts, is her phone listed as mobile or iPhone? Maybe that has to be changed?
    05-31-2013 06:03 PM
  10. groovy_guy's Avatar
    Yes! I switched from an iPhone 4S to a Nokia 928 (Win8), and haven't received any texts from my Verizon number. I've resorted to using Google Voice's SMS, not happy with Apple at the moment.
    06-11-2013 09:02 PM
  11. bubbly1970's Avatar
    Actually Galaxy phones just suck thats why it doesn't work. There is nothing wrong with iPhone.
    08-20-2013 06:44 PM
  12. wolfedude88's Avatar
    Actually Galaxy phones just suck thats why it doesn't work. There is nothing wrong with iPhone.
    Considering it is actually the result of switching from an iPhone it would have nothing to do with a galaxy phone or any other phone.
    08-20-2013 08:13 PM
  13. Jaryn Blaker's Avatar
    I have the same problem, I tried to send as a text message instead of an imessage and it won't work, getting very frustrated! Any other ideas?
    03-05-2015 02:49 PM
38 12

Similar Threads

  1. Official switching from Android to iPhone 4 thread
    By Rene Ritchie in forum iPhone 4
    Replies: 29
    Last Post: 11-21-2012, 03:35 PM
  2. Anyone switch back to Android?
    By durangojim#AC in forum iPhone 4
    Replies: 21
    Last Post: 02-09-2011, 03:14 PM
  3. My thoughts on switching from Android to iOS
    By durangojim#AC in forum iPhone 4
    Replies: 38
    Last Post: 01-14-2011, 11:32 AM