1. myblackz28's Avatar
    My 4s has 3 wifi signal bars and when I try an play YouTube vids it just crawls. Takes forever. Is there some sort of setting in my router that can fix this? Router is a netgear wndr 3700.
    10-28-2012 08:01 PM
  2. Mella's Avatar
    I know you can speed up YouTube streaming on iPhone with TCP Optimizer, but that work in the case of you’re willing to jailbreak.
    I don't know if could speed up YouTube by setting the router, as Im not use the YouTube official app, but Jasmine - YouTube Client, maybe you could have a try.
    10-29-2012 03:08 AM
  3. RWWackostu's Avatar
    I would recommend Jasmine as well.
    10-29-2012 10:04 AM
  4. myblackz28's Avatar
    I would rather not jailbreak. Sometimes YouTube vids load quicker on 3G. My router is new. I don't understand.
    10-29-2012 10:28 AM
  5. RWWackostu's Avatar
    I would rather not jailbreak. Sometimes YouTube vids load quicker on 3G. My router is new. I don't understand.
    You don't need to jailbreak to try Jasmine. If it is still slow using Jasmine, then it could be your WIFI. If not, it's the youtube app.
    10-29-2012 11:43 AM
  6. Jaguarr40's Avatar
    My 4s has 3 wifi signal bars and when I try an play YouTube vids it just crawls. Takes forever. Is there some sort of setting in my router that can fix this? Router is a netgear wndr 3700.
    I would for sure recommend the new You Tube App by Google. I like ther look and UI but mainly once you are signed in you get all your channels you have signed up for on your desktop computer and you can receive ALL videos even with short beginning ads where withthe Apple App you could not.

    Having said this I would check your router settings to make sure you have the latest firmware which is usually the main problem. If you have the latest firmware makesure all ofthe other settings inside your router are optimized to the point of being sure you are on the right setup for download speeds, Upload does not matter much. I don't knowwhat you have as far a a router that puts out "G" or "N" etc. but i have a netgear v7 with the latest formware and my You Tube videos don't buffer at all, They just play and very quickly so i hope this helps you and let us know and we can try something else. Also try the routers support page under FAQ to see what they recommend in settings for video maximizing.
    10-29-2012 01:59 PM
  7. myblackz28's Avatar
    I would for sure recommend the new You Tube App by Google. I like ther look and UI but mainly once you are signed in you get all your channels you have signed up for on your desktop computer and you can receive ALL videos even with short beginning ads where withthe Apple App you could not.

    Having said this I would check your router settings to make sure you have the latest firmware which is usually the main problem. If you have the latest firmware makesure all ofthe other settings inside your router are optimized to the point of being sure you are on the right setup for download speeds, Upload does not matter much. I don't knowwhat you have as far a a router that puts out "G" or "N" etc. but i have a netgear v7 with the latest formware and my You Tube videos don't buffer at all, They just play and very quickly so i hope this helps you and let us know and we can try something else. Also try the routers support page under FAQ to see what they recommend in settings for video maximizing.
    I just updated the router to the latest firmware. I dont think that did much. What sort of settings should I be changing in the router for optimal video performance?
    10-29-2012 03:21 PM
  8. Jaguarr40's Avatar
    I just updated the router to the latest firmware. I dont think that did much. What sort of settings should I be changing in the router for optimal video performance?
    I would go to the website of the router manufacturer as in Netgear, Linksys, Cisco etc and check and see that it supports the videos you are watching although I cannot imagine it would not. If you go to the FAQ section or even log into your router it should tell you in either place what to set your router settings for for optimum videos. Also I would unplug the power to your router, unplug your modem and turn off your computer. After that plug back in your modem, then router after all your modem lights are on and then turn on your PC or MAC. See if any of this makes a difference.

    EDIT: Are you using the Native You Tube App on 4S or did you upgrade to IOS6? If the latter i would DL like I said Googles You Tube App and even if you are still using 5.1.1 I would still DL Googles new you Tube App for free. I love it and it is very fast.
    10-29-2012 05:54 PM
  9. myblackz28's Avatar
    I'm on ios6. Also using the google YouTube app. It's a great app when my connection is quick.
    10-29-2012 06:16 PM
  10. ITS ME DAVID's Avatar
    To to wifi then click on your router name then scroll down to DNA and enter this end and delete yours 8.8.8.8 then wack out to wifi to save settings and restart phone should be faster
    10-30-2012 01:29 AM
  11. Peligro911's Avatar
    To to wifi then click on your router name then scroll down to DNA and enter this end and delete yours 8.8.8.8 then wack out to wifi to save settings and restart phone should be faster
    Or log into your router and replace the DNS so it automatically assigns it to all devices
    10-30-2012 01:50 AM
  12. myblackz28's Avatar
    To to wifi then click on your router name then scroll down to DNA and enter this end and delete yours 8.8.8.8 then wack out to wifi to save settings and restart phone should be faster
    I don't see any DNA setting. Not sure what you mean.

    - - - Updated - - -

    Or log into your router and replace the DNS so it automatically assigns it to all devices
    How do I replace the dns? Not that familiar with router settings. Can I trouble you for step by step directions?
    10-30-2012 09:45 AM
  13. Peligro911's Avatar
    It should be on your wireless setup page I don't have your router so I'm not sure first I would try doing what was said just change it on the phone first to see if it fixes your issue
    Go to wireless on your phone on your network press the blue arrow it will then show the IP address etc scroll down till you see dns and manually type in the 8.8.8.8 back out and try YouTube


    Beamed from my iPad 2 routed and bouncing across the globe on multiple servers and brought to you using Tapatalk !
    Jaguarr40 likes this.
    10-30-2012 04:09 PM
  14. myblackz28's Avatar
    It should be on your wireless setup page I don't have your router so I'm not sure first I would try doing what was said just change it on the phone first to see if it fixes your issue
    Go to wireless on your phone on your network press the blue arrow it will then show the IP address etc scroll down till you see dns and manually type in the 8.8.8.8 back out and try YouTube
    In my router it says DNS is set to: Get automatically from ISP. I should just change it to 8.8.8.8?
    10-30-2012 04:35 PM
  15. Peligro911's Avatar
    In my router it says DNS is set to: Get automatically from ISP. I should just change it to 8.8.8.8?
    Yes exactly
    10-30-2012 05:45 PM
  16. Jaguarr40's Avatar
    My 4s has 3 wifi signal bars and when I try an play YouTube vids it just crawls. Takes forever. Is there some sort of setting in my router that can fix this? Router is a netgear wndr 3700.
    What Peligro is referring to is indeed on your Routers setup page and stands for Domain Name Server (DNS)
    It should be on your wireless setup page I don't have your router so I'm not sure first I would try doing what was said just change it on the phone first to see if it fixes your issue
    Go to wireless on your phone on your network press the blue arrow it will then show the IP address etc scroll down till you see dns and manually type in the 8.8.8.8 back out and try YouTube

    Beamed from my iPad 2 routed and bouncing across the globe on multiple servers and brought to you using Tapatalk !
    You are right Peligro and i have done this myself and my last iPhone and it does speed things up so i hope the OP listens to you and tries it. He has nothing to lose.
    10-30-2012 07:10 PM

Similar Threads

  1. YouTube slow on my ipad
    By silva44 in forum Original iPad
    Replies: 8
    Last Post: 06-26-2011, 12:59 PM
  2. NEED HELP!! my app is very slow
    By Theappguys in forum iPhone Apps & Games
    Replies: 0
    Last Post: 09-29-2010, 04:07 PM
  3. Youtube is really slow on my iPad
    By CharlieBall in forum Original iPad
    Replies: 29
    Last Post: 09-28-2010, 10:36 AM
  4. Google Voice / Gizmo 5 on my WiFi iPad
    By TheMooch in forum Original iPad
    Replies: 12
    Last Post: 07-10-2010, 02:24 AM
  5. YouTube isn't working on my phone.
    By 3seven1 in forum iPhone 4
    Replies: 9
    Last Post: 03-30-2010, 08:55 PM
LINK TO POST COPIED TO CLIPBOARD