1. htabbach's Avatar
    Hello all,

    I am having issues with wifi, I lose connectivity to the internet although I am still connected to the wifi network, I have to disconnect and reconnect to regain connectivity to the internet, my wife's iPhone 4 does not have any issues with the same networks I am having issues with. These issues were there before the latest updates and still there after the updates. I thought it was specific to my phone but my sister's 4s has the same issues with the same networks I am having issues with. When the phone sleeps I lose the internet, I have to disconnect from the wifi and reconnect to regain internet access. Also on my parents wifi, I have to put the password every time I connect, my sister's 4s does the same but my wife's 4 is perfectly fine. Does the 4s have known problems with wifi?

    I tried resetting the network settings and I did a complete reset on my phone with no luck, any ideas?
    10-17-2012 12:38 PM
  2. Just_Me_D's Avatar
    I have a 4S and I have never had an issue connecting to and maintaining a connection to a Wi-Fi network. Do you, by chance, have any restrictions set via your router or access point that might disconnect the 4S devices after a period of time? Do you have some sort of battery saving app installed that might auto-disconnect your device for a Wi-Fi network? When you reset your device, did you restore as new or restored from a backup? If you restored from a backup, reset your device again using iTunes and restore it as new.
    10-17-2012 12:52 PM
  3. ThePinkChameleon's Avatar
    Have you tried rebooting your router? What type of router are you using?

    Also, in regards to the wifi - when the phone sleeps it will go to a 3G connection, that is normal. Now, when you wake up the phone, it usually takes a second or two, and the wifi will automatically reconnect itself. Just to be clear, Is that what your not seeing happen?
    10-17-2012 12:52 PM
  4. rdiddy_25's Avatar
    Is it just with your wifi network or does this happen on all networks?
    10-17-2012 12:58 PM
  5. plt3121MarineAlways's Avatar
    I seem to be having the same issue. Mine however started happening recently not right after updating to 6
    10-17-2012 02:20 PM
  6. htabbach's Avatar
    Is it just with your wifi network or does this happen on all networks?

    Certain ones, mine and my parents. My 4s and my sister's 4s, we need to enter the password every time we connect, it does not save the password it seems nut my wife's 4 works perfectly fine! This is strange!
    10-17-2012 02:45 PM
  7. ThaKrazyOne's Avatar
    Another possible solution is to forget the network, and setup the wifi access again. Also another is to reset all network setting, which is something I did with my iP4 and worked.
    10-17-2012 11:58 PM
  8. plt3121MarineAlways's Avatar
    I actually tried that and it's helped so far. Thanks.
    10-18-2012 07:41 PM

Similar Threads

  1. Wifi slower on my 4s than 3g
    By JustinKoenig in forum iPhone 4S
    Replies: 3
    Last Post: 10-31-2011, 01:32 PM
  2. Wifi setting grayed out on 4S??
    By Solen in forum iPhone 4S
    Replies: 2
    Last Post: 10-19-2011, 10:27 PM
  3. Wifi issues on my 3G
    By 132_and_bush in forum iPhone 4
    Replies: 0
    Last Post: 11-12-2010, 08:36 PM
  4. WiFi issues on iphone4
    By tharrington2 in forum iPhone 4
    Replies: 0
    Last Post: 06-24-2010, 09:38 PM
  5. Iphone 3GS Wifi Issues on 3.1
    By MGT in forum iPhone 3GS Forum
    Replies: 2
    Last Post: 09-15-2009, 02:01 PM
LINK TO POST COPIED TO CLIPBOARD