1. 74256274's Avatar
    I have two App Store apps (Chime &GymGoal) that have built in notification sounds. Both sounds are overridden by one of my custom ringtones. The built-in tones are completely ignored even though I can seemingly set them and*play them in the app. But when it comes time to play the notification while running the app, it plays my custom ring tone rather than the selected sound.*Placing the phone on vibrate has no effect either, the sound still plays. The sound also doesn't play through my earphones.

    If I change the name of the ringtone file using iFile, those two apps*won't play any sound at all, even the selected sound from he apps. If I swap the name of the ringtone with another ringtone, those two apps*play the new sound with that filename. I've deleted the apps a couple of times and wiped the cache etc. but no luck. The same problem even followed me when I upgraded to 5.1.1 and re-jailbroke my phone. I thought a total restore would have fixed it, but it didn't. So I'm guessing it is caused by some preference file that remained during the restore process.

    Any ideas?
    05-28-2012 02:13 PM
  2. BreakingKayfabe's Avatar
    I think I may or may not be following what you're saying. With that said, I see you're jailbroken. Have you
    tried to just use PushTone from Cydia? It's easier to set notification tones for 3rd party apps with.
    05-28-2012 03:59 PM
  3. kch50428's Avatar
    yes, you've got something "stuck"... go to Settings>> General>> Reset>> Reset settings then go back and re-setup your customizations.
    05-28-2012 04:09 PM
LINK TO POST COPIED TO CLIPBOARD