1. Recipe7's Avatar
    First off. I have a jailbroken 4s 32gb running on 5.0.1. It's white, hehe. It is factory unlocked.

    To be as thorough as possible, I would like to explain my situation so there won't be any confusion.

    Two weeks ago I downloaded the iBirthday app from Cydia. Soon after I realized that my battery life would drop overnight about 20% within the span of 8 to 9 hours.

    I didn't know it was the iBirthday app causing the drain of my battery. I figured it out using OpenNotifier by using a specific icon for ALL of my apps on my phone so whatever is running in the background, an icon will display on the status bar. So the only icon which showed on the status bar was the iBirthday app icon. I swiftly uninstalled that app and the phone was back to normal, 2-3% drain of my battery overnight.

    Now fast forward to 2 days ago. I was using my 4s like I usually do, then realized that the battery was draining fast again. Within a 3 hour idle, it dropped 7% in battery life.

    I didn't install any apps within this time frame, so it can't be any of the apps currently installed (I may be wrong though).

    To be more clear about the status of my 4s, the wifi is off, the bt is off, push is off, fetch is manual.

    At this time, it is still draining about 1 percent every 20-30 minutes at idle.

    I tried resetting network settings, tried deleting and reinstalling all my mail accounts. Nothing.

    What is the problem here?
    05-17-2012 04:18 PM
  2. 1982ollie's Avatar
    I know that there where some problems with battery life and 5.0.1. There should be other members here to confirm this. I would live with it until the new jailbreak is out which we are hoping will be a couple of weeks at best. Then upgrade and re-jailbreak 5.1.1.

    That is what I would do. But someone else may be able to shed some light. If you are saying it was ok running 5.0.1 then it is a bit weird. Do you have a winterboard theme running, as I know that can drain battery pretty bad when running a theme. I used to have that and I removed it and I must say my battery life is much better for it.

    Hope you get to the bottom of it. Like I said we are hoping this new jailbreak utility isn't far away.


    Sent from my iPhone using Tapatalk
    05-17-2012 05:14 PM
  3. Recipe7's Avatar
    Thanks for your reply ollie.

    Yes, I am using typophone as my theme under winterboard. I am using the iphone version of this: HOW TO MAKE BEAUTIFUL LOCKSCREEN ON IPAD 3

    But I don't think it would be the culprit in my situation. I have been using that theme since the 2nd day I've had the 4s, which was April 27th.

    Either way, I am still doing a rundown on the apps and will be testing them. As far as I know, the ibirthday app is buggy and drainy, so I will see if any other apps are doing the same thing to my 4s.

    I hope the jb for the 5.1.1 is out soon. I will have to deal with this for now I suppose.
    05-17-2012 06:47 PM
  4. Recipe7's Avatar
    I'm not sure if anyone is aware of using putty/winSCP to access the iphone's processes.



    Here is a printscreen of the processes of my iphone. I find something a bit odd. My springboard is constantly using up cpu, between 1-7 percent, mostly around 5%. Under RSIZE it also shows that it has 42M, compared to other processes which shows K. I presume this means 42million kilobytes, and the other processes are low numbers in kilobytes.

    Is something wrong with my springboard? CPU usage also shows 5-6percent usage, and idle is at 94-95%. Mind you that these are numbers while my 4s is locked.

    Can anyone shed some light on this?
    05-18-2012 01:00 AM
LINK TO POST COPIED TO CLIPBOARD