1. mabjr177's Avatar
    Ok guys i am on Verizon with a 4s and got it yesterday all day and night it would drop signal and would say no service. I did some reading and tried erasing all data and network setting and started from scratch with out it connect to itunes on my PC and now im having no battery or data connection issues just wanted yall to know it may help.
    Just_Me_D likes this.
    05-09-2012 10:05 AM
  2. Just_Me_D's Avatar
    Thank you. As I've stated on numerous occasions, when things get screwy, start from scratch...
    05-09-2012 10:34 AM
  3. mabjr177's Avatar
    No problem yeah still going strong not one issue couldn't be any happier.
    05-09-2012 01:07 PM
  4. mabjr177's Avatar
    Update still no issues been using it heavily drain the battery fully the other day when i picked it up and put in on the charger yesterday around 10 AM. got it fully charged and been using it all day yesterday and this morning and im at 43%. It did have a over heat problem when i picked it up at Best Buy but when i did the Erase all content and Settings from the phone it took care of if the battery drain, overheating issue and lose of signal randomly. Im on Verizon 4s.
    05-10-2012 09:08 AM
  5. mabjr177's Avatar
    Some how i think itunes may be part of the problem, once i restored the phone then disconnected it from itunes to start the phone from scratch it was fine but when trying to redue the phone connected to itunes the issues pursisted. Just my experience
    05-10-2012 09:13 AM
LINK TO POST COPIED TO CLIPBOARD