1. roy38hk's Avatar
    Please help.
    In my old pc win xp,both iphone 4, and 4swork fine.
    New pc Win7 64bit( Home SP1) can't detect iphone 4s (no jb) .But can detect Ipone 4.
    Install and uninstall Itune several timesResult is the same.
    Itune version 10.6.1.7 (64 bit)
    iphone4s version 5.1(9B179).
    All the Services running in control pannel.
    No Apple Mobile Device Usb driver in Device manager.
    But if i connect old Iphone 4,all works.


    Many thanks...
    04-06-2012 08:07 AM
  2. joe_fresh's Avatar
    have you checked apple's site for add-on for 64 bit? i am running 64 bit as well but with a plain 4
    04-06-2012 08:10 AM
  3. joe_fresh's Avatar
    iOS: Device not recognized in iTunes for Windows check here, was the first thing google pulled up


    https://discussions.apple.com/thread...art=0&tstart=0 or here
    Last edited by joe_fresh; 04-06-2012 at 08:17 AM.
    04-06-2012 08:14 AM
  4. roy38hk's Avatar
    cannot find any addon for 64bit in apple's site,eventhough i go through the link you provide,still
    no device found in" device manager:.
    Thanks,
    04-06-2012 10:08 AM
  5. iNation's Avatar
    I have a win7 64 bit and my computer does detect my iPhone 4s.
    04-06-2012 10:25 AM
  6. sting7k's Avatar
    Please help.
    In my old pc win xp,both iphone 4, and 4swork fine.
    New pc Win7 64bit( Home SP1) can't detect iphone 4s (no jb) .But can detect Ipone 4.
    Install and uninstall Itune several timesResult is the same.
    Itune version 10.6.1.7 (64 bit)
    iphone4s version 5.1(9B179).
    All the Services running in control pannel.
    No Apple Mobile Device Usb driver in Device manager.
    But if i connect old Iphone 4,all works.


    Many thanks...
    Does Windows make any acknowledgement that you plugged it in via USB? Or does nothing happen at all?
    04-06-2012 10:38 AM
  7. kch50428's Avatar
    Please help.
    In my old pc win xp,both iphone 4, and 4swork fine.
    New pc Win7 64bit( Home SP1) can't detect iphone 4s (no jb) .But can detect Ipone 4.
    Install and uninstall Itune several timesResult is the same.
    Itune version 10.6.1.7 (64 bit)
    iphone4s version 5.1(9B179).
    All the Services running in control pannel.
    No Apple Mobile Device Usb driver in Device manager.
    But if i connect old Iphone 4,all works.


    Many thanks...
    Plugging in via USB hub or direct into a USB port on the PC?

    If via hub - try direct to the PC.

    Yes, that can make a difference.
    04-06-2012 10:47 AM
  8. iRetired's Avatar
    When you right-click on Computer on the Desktop, choose Properties, then Device Manager.

    To have a solid connection to your iPhone 4S you should have the following:
    Under Portable Devices: Apple iPhone
    Under Universal Serial Bus controllers: Apple Mobile Device USB Driver

    For Local Services, on the Extended tab, Apple Mobile Device must be present and it should be started.

    One time I plugged in my iPhone and I had not started the Apple Mobile Device service. I received a pop-up saying I could not connect to iTunes.

    Maybe there's a site where you can download the correct drivers. Google it. My win64 laptop did it all automatically.
    04-06-2012 11:06 AM
  9. hellomiggy's Avatar
    Uninstall everything that is Apple Related on your computer. Apple Mobile Device, just click on the middle row and it'll Alphabetize everything and uninstall, everything that is Apple. I mean everything Even if it is Safari or Quicktime I uninstall it.

    Done... Good

    Download iTunes 10.6.1 (64-bit) - FileHippo.com

    There is the link for the 64 bit version, Download it.... don't install once it is done.

    Restart your computer, once everything is running, install iTunes. Hopefully it works.

    I had this problem before several times, it works. I just hate doing it.
    04-06-2012 12:00 PM
  10. 3cit's Avatar
    Yeah let's see if his iPhone 4s is maybe the problem! It's not his windows setup as it recognizes other apple devices, including iPhone do drivers and services are running properly!
    Looks like the 4s is having an issue, is it (the 4s) recognized by OTHER computers?
    04-06-2012 02:10 PM
  11. roy38hk's Avatar
    Uninstall everything that is Apple Related on your computer. Apple Mobile Device, just click on the middle row and it'll Alphabetize everything and uninstall, everything that is Apple. I mean everything Even if it is Safari or Quicktime I uninstall it.

    Done... Good

    Download iTunes 10.6.1 (64-bit) - FileHippo.com

    There is the link for the 64 bit version, Download it.... don't install once it is done.

    Restart your computer, once everything is running, install iTunes. Hopefully it works.

    I had this problem before several times, it works. I just hate doing it.
    Hi,i've uninstalled all Apple related driver and softwares,and installed the Itune you direct to me.
    But the result is not work.I plug the 4s directly to USB port,no pop up message from Windows that hardware is detected. No Apple mobile devise usb driver found.
    By the way,when i plug the old Iphone 4 in usb port,window can detect ,can connect itune too.
    Anyway,thanks for all your people's advise,i might consider to downgrade my pc to xp.
    04-07-2012 09:03 AM
  12. cctpitts01's Avatar
    Based on everything you have said I believe that you may have an issue with your phone rather then your computer. If the iPhone 4 works and currently I have 2 iPhone 4s between me and my fiancé and we both have 2 laptops that are running Wins7 64bit OS with no problems and you have repeatedly deleted all the drivers and everything Apple related and reinstalled and still the same outcome its most likely a phone issue.


    Sent from either my Evo 3D or my iPhone 4s.
    04-07-2012 10:45 AM
  13. Lodingi's Avatar
    Try a different USB cable. I had this problem with various Android devices.

    Also try different USB ports.


    Sent from my iPhone 4s using Tapatalk
    04-07-2012 06:12 PM
  14. pstitare's Avatar
    I am using 64 bit system and want to take a backup of iPhone MC705ll/a on that system.
    Initially, when i connect my iPhone to the system with all apple drivers installed, it shows
    device as a drive on My Computer, and its properties are also visible with device id etc.
    but when I used 'mobiledit' software to take the backup it shows "device not connected properly, please disconnect and connect again"

    I have done that several times, also i have uninstalled and installed drivers multiple times, but it wont work.
    Also even after this My Computer continue to show the device as a Drive.
    08-25-2014 02:31 AM
  15. pstitare's Avatar
    however when I connect the iPhone to 32 bit system, it allows me to to take the backup
    but connecting same iPhone to a 64 bit system with apple 64 bit drivers installed,
    it wont show the device under "Connected device".
    08-25-2014 03:51 AM
LINK TO POST COPIED TO CLIPBOARD