1. vvelvetelvis#CB's Avatar
    every day i have to restart my phone because it stops connecting to the data network. once i restart it, it connects no problem but sometime in the next day or two it wont connect again and i have to restart it.

    this doesnt seem right. any suggestions?

    thanks
    Last edited by velvetelvis; 03-24-2012 at 10:52 AM.
    03-24-2012 10:38 AM
  2. itsalexaye's Avatar
    what carrier do you have? You may want to take it in to their store so they can take a look and see what's wrong.

    Does WiFi work fine?
    03-24-2012 12:08 PM
  3. IAmSixNine's Avatar
    Had a friend who had an iPhone 4, then upgraded to a 4S and gave me the SIM for the 4S and he kept the phone. Long story short after a few days of using a 4S with his 4 Sim he was having the same issue.
    He called ATT and had them update the account and no problems.
    You need to provide us with more info to be able to help you better trouble shoot.
    03-24-2012 06:03 PM
  4. velvetelvis's Avatar
    My bad. Wifi works. I'm on AT&T. I know, that alone might be my problem. But I never had this problem with my wp7 phone. The sim was new with the phone. Going to try restoring to new phone settings and see how that works before going in.
    03-24-2012 08:23 PM
  5. jamesedward318's Avatar
    I'm on Verizon and I have a 4S and I too am having that issue. Sometimes when I go to connect to the web, Facebook, Tweetbot/Twitter or anything else web related I have this same issue.
    03-25-2012 02:51 PM
LINK TO POST COPIED TO CLIPBOARD