1. poutinegalvaude's Avatar
    Hello everyone, 1st poster here...

    I just bought my first 4S. It's an Apple unlocked version, but I can't get the SIM card I bought here in Brazil (through Claro) to work. Every time I insert the SIM the phone searches for about 3 minutes and then says, "no signal":

    Using my co-workers' SIM cards (both Brazilian through Claro/Vivo/Tim/Oi and international through Vodafone, Orange, and Rogers) work fine in my phone.

    My SIM card works fine in my co-workers' phones. If it was an issue with cutting my SIM cards, it wouldn't work in anyone's phone...would it?

    I'm not getting any "bad SIM', "SIM card failure", "invalid SIM", or "no SIM" error messages. Matter of fact is I'm not getting any error messages at all. I've reset the network settings, done a restore on the phone, and fully restored the phone through iTunes but still no joy.

    Has anyone else experienced this?
    12-16-2011 11:44 PM
  2. Guacho's Avatar
    I had the same issue here in the US with the unlocked iphone 4S, when I got it I just put it my old iphone 4 sim card and it didn't work, go to your provider and get a new sim card, that did it for me...
    12-17-2011 06:40 AM
  3. poutinegalvaude's Avatar
    Thanks for the reply, but I've gone through 3 different SIM cards with the same result. Other peoples' SIM cards work in my phone just fine, and my card in theirs...
    12-18-2011 04:09 PM
  4. Cleveland's Avatar
    I'd try going to apple and seeing if somehow its a hardware issue...
    12-18-2011 08:05 PM
  5. Guacho's Avatar
    Thanks for the reply, but I've gone through 3 different SIM cards with the same result. Other peoples' SIM cards work in my phone just fine, and my card in theirs...
    You mean other sim cards from the same network?? That is weird...
    12-18-2011 08:15 PM
  6. poutinegalvaude's Avatar
    Yes, other SIM cards from the same network, plus I've tried SIM cards from other networks that work in other peoples' phones. I have cut the cards myself, so I'm going to try to buy a micro-SIM card outright and see if that works any better.
    12-18-2011 08:49 PM
  7. poutinegalvaude's Avatar
    I'd try going to apple and seeing if somehow its a hardware issue...
    I totally would but I'm on tour in Brazil and South America for the next 2 years and there are no Apple Stores here
    risingofthephoenix likes this.
    12-18-2011 08:50 PM
  8. Guacho's Avatar
    Where did you get your iphone?? Call Applecare from where you are, you have 90 days of Applecare from the moment you got your iphone, Applecare does iphone swaps but I'm not sure here since you're overseas.
    12-19-2011 12:30 PM
  9. poutinegalvaude's Avatar
    I bought an official micro-SIM card from Claro and it worked a treat. The 4S seems really sensitive to badly cut SIM cards. Thanks for all the help.
    12-21-2011 11:18 PM
LINK TO POST COPIED TO CLIPBOARD