1. tohamyn's Avatar
    It doesn't seem to like me very much. I keep telling it who my brother and dad are, and it is reluctant to remember.

    Me: Ahmed is my brother
    Siri: Do you want me to remember that Ahmed is your brother?
    Me: Yes
    Siri: Okay, I will remember it.

    then...

    Me: Call my brother
    Siri: Who is your brother?

    Imagine this for 2 hours! The only person it remembered is my wife, which is weird. Any suggestions? I'm trying to get through to Apple Care but no one seems to be available to help!
    10-25-2011 04:51 PM
  2. verwon's Avatar
    Have you set up the relationships in your contacts?

    If you're syncing them through exchange, such as Google, it doesn't have the relevant fields necessary to save the information.


    Sent from my iOS ecosystem!
    tohamyn likes this.
    10-25-2011 04:53 PM
  3. tohamyn's Avatar
    So how do I fix that? I think thats the problem.
    10-25-2011 05:04 PM
  4. verwon's Avatar
    Switch your contacts to iCloud. Do you use a PC or a Mac? There are different ways for each.


    Sent from my iOS ecosystem!
    tohamyn likes this.
    10-25-2011 05:11 PM
  5. tohamyn's Avatar
    Switch your contacts to iCloud. Do you use a PC or a Mac? There are different ways for each.


    Sent from my iOS ecosystem!
    I have a mac. So as soon as I switch the synching to iCloud I shouldn't have anymore issues?
    10-25-2011 05:14 PM
  6. verwon's Avatar
    Yes, when you switch your contacts to it, you'll get the proper relationship fields that Siri can save. I had the same problem, so I switched all mine over.


    Sent from my iOS ecosystem!
    tohamyn likes this.
    10-25-2011 05:16 PM
  7. tohamyn's Avatar
    Woo! Worked like a charm!! Thanks a lot!
    10-25-2011 06:40 PM
  8. verwon's Avatar
    Very welcome!


    Sent from my iOS ecosystem!
    10-25-2011 06:41 PM
  9. JustinHorn's Avatar
    I use exchange for my main contacts, but have my person contact that Siri uses on iCloud to use it to the full functionality. I like that I can have both enabled.
    10-25-2011 07:02 PM
LINK TO POST COPIED TO CLIPBOARD