1. euroflyer's Avatar
    Yes, I know Virgin Mobile do not support the iPhone family, yet, for over a year, I have been using an iPhone 4 very successfully with my Virgin Mobile sim card. I used a micro sim card cutter to trim it to the required size and it has worked fine until now.

    Today was the iPhone 4s release date and I had been waiting, excitedly, for the phone to arrive, having ordered it a week ago. Why? The faster processor and the virtual assistant, Siri.

    I followed the instructions to transfer everything from the old iPhone 4 to the new iPhone 4S. Took out the old sim and put it in the new phone. For a moment everything worked fine. I made a test call, no problem. After five minutes the message SIM FAILED appeared and then, in the provider space INVALID SIM.

    Has anyone else had this issue? There must be others using iPhones on Virgin, here in the UK.

    I called Apple. They had no clue what might be wrong. I called Virgin Mobile, who said my sim card may be too old and they will send me a new one.

    I tried another Virgin (known to work) sim in the phone and it did the same thing. I wonder if all new iPhone 4S's are going to have this incompatibility or do I just have a duff one?

    To recap, the sim still works perfectly in the old iPhone 4 and I have not jailbroken either one.

    Anyone have any thoughts, suggestions, constructive information?
    10-14-2011 01:34 PM
  2. pokey318's Avatar
    I thought I read that the iPhone 4s had a different sim card, but don't know for a fact if this is true.
    10-14-2011 02:03 PM
  3. cristalD's Avatar
    well I faced the same problem so I have returned the phone to the store of purchase and they replaced the original SIM. This made no difference whatsoever.
    10-20-2011 01:30 AM
  4. mustang8918's Avatar
    I was getting that sim failure alot on Tuesday of course it would clear for a little while when I restarted it but then would go back to sim failure. I ejected the sim and put it back in and haven't had the problem again so far.
    10-20-2011 05:55 AM
  5. mustang8918's Avatar
    Just had the sim failure pop up again, this sucks.
    10-20-2011 08:10 PM
  6. robes1's Avatar
    I had the same problem and I'm on AT&T. It only happened twice and on the same day but never again.
    10-20-2011 08:37 PM
  7. mustang8918's Avatar
    This is what happened to me, after three trips to the store to show them the sim failure we called at&t tech support and tech support told the store to put in a new sim card and I've been good all day since then and hopefully it holds up. One other thing the tech guy told me when we called him, he said that my account didn't show a sim number, so that could have been the problem all along, that my account wasn't totally set up correctly in the beginning.
    10-21-2011 11:14 PM
LINK TO POST COPIED TO CLIPBOARD