1. Hobbit#IM's Avatar
    So I've been trying to upgrade from Beta 1 to Beta 2 on my iPhone 4 (GSM) but I keep getting an error saying that the firmware is not compatible with this device.

    I have itunes 10.5B2, (reinstalled a couple times)

    I have tried on both mac and pc and both give the same error.

    Redownloaded the ipsw a few times.

    I do command/shift restore and select the restore file and as soon as i press open the message box pops up saying "The iPhone "XXX's iPhone" could not be restored because the firmware file is not compatible.

    I also gave it a shot by putting it in DFU mode and trying, still not luck.

    There were no error codes given and I cannot find anyone having this issue, everyone else is having an issue with them pressing the update instead of restore button.



    Any advice?
    06-29-2011 02:39 AM
  2. lilmoe's Avatar
    Make sure you have the right firmware for your device and that your hosts file is not edited.
    Hobbit#IM likes this.
    06-29-2011 07:02 AM
  3. Ipheuria's Avatar
    ^^^^ Ding Ding Ding, check the link in my sig to make sure your hosts file is not edited which is my best guess at this time.
    Hobbit#IM likes this.
    06-29-2011 07:14 AM
  4. BLiNK's Avatar
    check to see if your ipsw file has downloaded completely. the file size should be like 817mb

    i read elsewhere that people were only getting around 200kb of the download and then would receive the same error
    Hobbit#IM likes this.
    06-29-2011 07:47 AM
  5. Hobbit#IM's Avatar
    Firmware version is correct, host file is not altered from windows default.

    I checked the file i currently had on my desktop and it was 40.5mb. Im not sure about the other times i downloaded because I deleted them. Im re-downloading it again and we'll see if I get the full file and if the error goes away.
    06-29-2011 01:28 PM
  6. ek9max's Avatar
    I know your problem. You aren't a true develpoer so you either downloaded a .DMG file or a zip file.

    you cant simply rename the extention to .ipsw like we did when jailbreaking.

    You have to uncompress the zip file or convert the dmg file.

    You can google on how to convert a DMG file.

    P.s I had the same problem
    06-29-2011 09:26 PM
LINK TO POST COPIED TO CLIPBOARD