1. apallatto#IM's Avatar
    I just recently for Comcast and I have their Arris gateway. A laptop, desktop, 2 iPads, and my wife's 4s connect to it fine but for some reason my 4 can't. I get the wifi symbol but when I try to do anything nothing loads and after waiting a while I get a screen that says safari can't connect.i have tried changing the security settings as well as the channel. I tried forgetting the network and turning wifi on and off. I just recently tried restoring my iPhone as new. Nothing works. I can't seem to find anything other than those options to try and fix it. Thanks for the help.
    09-30-2012 02:41 PM
  2. Peligro911's Avatar
    Hook a router behind your gateway or have Comcast give you. Standalone modem .. Search the forum this is a issue other have as we'll but with sending pics
    09-30-2012 02:46 PM
  3. Doctorken100's Avatar
    Unplug your router and plug it back in. I have this problem with my iPhones and also my printer. It works after a router reset.
    09-30-2012 08:21 PM

Similar Threads

  1. 3G doesn't connect but wifi does
    By Robsmom10 in forum Original iPad
    Replies: 0
    Last Post: 10-16-2011, 10:09 AM
  2. Wifi connect - No internet access
    By iDev in forum iPad 2
    Replies: 0
    Last Post: 07-30-2011, 08:46 PM
  3. Can not connect to my Wifi no more
    By blueman1#IM in forum iPhone 4
    Replies: 1
    Last Post: 11-27-2010, 03:24 AM
  4. Can't connect to SAFARI via WiFi
    By GiLmo in forum iPhone 4
    Replies: 3
    Last Post: 10-15-2009, 11:08 PM
LINK TO POST COPIED TO CLIPBOARD