1. BobDeere's Avatar
    Hi all
    purchased these one here in Sweden,,its stone dead.. so i opened it
    found some burn marks and also some white powder around the battery area..
    you cann see the marks on the lower right side of the 1 pic.


    Shot at 2012-09-13

    here you can see some green oxide around the battery connector


    Shot at 2012-09-13
    and under the plastic film beneith the battery the chassie is kinda of whitish on the surface..
    any idea what happend?
    is the battery gone? can i try to clean the connectors form the oxide? can i do that and how?
    or should i buy new parts?
    cheers
    Robert
    09-13-2012 12:08 PM
  2. joe_fresh's Avatar
    Looks like water damage on from my view. From what i am seeing you just purchased an expensive paper weight.
    09-14-2012 07:34 PM
  3. Tanbam's Avatar
    This got wet - really wet - and stayed that way for a long time. That corrosion is just the tip of your iceberg. The more you dissassemble it, the worse it's going to look. It's not salvageable.
    09-15-2012 01:30 AM
  4. BobDeere's Avatar
    a few questions
    what parts are usually gone then? all?
    what abouth the main board?
    i saw on ebay both in the UK and US that mainboard are sold for lots of money.. even if they are non working..
    maybe the best solution will be to brake it and sell it in parts?

    cheers
    Robert
    09-15-2012 01:46 AM
  5. Peligro911's Avatar
    I would take it apart in see how bad the connectors are get to board if you see same on actual board it's toast if not try cleaning it def need new battery .. Screen .. For starters but it's a longggg shot but I would do it just for fun lol although it looks bad and prob a list cause .. Sell it on eBay as water damage no power I'm sure you can get some money for it
    09-15-2012 02:34 AM
  6. BobDeere's Avatar
    i have already started to do that .. the connectors are already nice and shining after i used a dry toothbrush. im stucked with one very tigh screw that doesnt comes loose otherwise most of the parts are gone..
    09-15-2012 02:40 AM
  7. BobDeere's Avatar
    manage to disassembly the phone..
    the mother board dont look that awfull.. there was some surface rust on the left side "the chip" on the pics
    but i thing it was must surface rust form the shield that protected it..



    Uploaded with ImageShack.us
    09-16-2012 03:32 AM
  8. BobDeere's Avatar
    heres the pic of the motherboard



    Uploaded with ImageShack.us

    as you can see it doesnt look that bad..
    there was some surface rust on the chip on the left side of the pic but i think it came fron the heat shield..
    09-16-2012 04:51 AM
  9. Tanbam's Avatar
    it's not the rust you see, it's the rust that you don't see. That board looks rough to me. Even with the low resolution picture, you can easily see the discolored pads in the array of circles in the upper right. You're not still trying to fix this, are you?
    09-20-2012 09:24 PM
  10. BobDeere's Avatar
    I have all the parts needed to built it.. as soon i have some time ill try..
    09-21-2012 01:09 AM
LINK TO POST COPIED TO CLIPBOARD