1. buzzshipman's Avatar
    I have a jailbroken iPhone 4. I broke the screen and bought a replacement and installed it and the phone worked just fine except the screen was messed up. I bought another screen and just replaced it and the screen is perfect except now I can not get a cell signal. WIFI is fine and I get a cell signal sometimes just very weak and mostly when I am outside of a building. If I'm in my house or when I was just at work, I get no signal. When I walk outside It does pick up a signal sometimes. Did I mess up the antenna somehow or what is happening.

    Thanks,
    Kevin
    05-20-2012 05:23 PM
  2. Tanbam's Avatar
    I'd open it back up and make sure that all of the antennas and other connectors are mounted correctly.
    05-20-2012 05:49 PM
  3. buzzshipman's Avatar
    I'd open it back up and make sure that all of the antennas and other connectors are mounted correctly.
    I did that. That is what I thought of first. I assuming the 3 connectors next to where the screen hooks up is the antenna connectors. I pulled them up and reconnected them but still the same thing. Is there something else that I am missing, maybe I moved something.
    05-20-2012 07:08 PM
  4. Peligro911's Avatar
    I think in the bottom there is a circle connector looks like a wire with a tiny circle on the end


    Sent Into Orbit from my iPhone 4S using Tapatalk
    05-20-2012 10:41 PM
  5. Peligro911's Avatar
    The 3 connectors are the digitizer .. LCD and ear speaker


    Sent Into Orbit from my iPhone 4S using Tapatalk
    05-20-2012 10:45 PM
  6. Fixxy's Avatar
    The grease on your fingers has the ability to cause wireless interference. Make sure you clean all metal to metal contacts with windex or something similar, and completely dry before reconnecting. Also make sure you didn't lose the sign booster clip.
    05-26-2012 10:33 PM
LINK TO POST COPIED TO CLIPBOARD