1. jtanko78's Avatar
    I have recently been getting this message when going to install or update apps from the app store on my iphone 4. Has anyone else seen this or know why it might be happening? It happens when the initial password window pops up to enter you password to allow install or updates. It seems to lag behind when typing in the password. Then the error appears stating it could not purchase a specific app (the same app everytime is mentioned, on my device it is mapquest 4 mobile by AOL) and 10 other ones as well. After hitting continue, it returns back to the password screen to continue entering your password. I wondered if they were updates for apps that were just not working correctly, but when I checked, all the apps are up to date on my device.
    02-25-2012 03:36 PM
  2. Massie's Avatar
    I get this as well: it's for an app I no longer have on my phone (iLoader) and "2 other apps" that I haven't identified. Very annoying, if only because I can't figure out what's causing it. There is quite a discussion on the Apple forums about it: https://discussions.apple.com/thread...art=0&tstart=0
    02-25-2012 04:07 PM
  3. Wildo6882's Avatar
    I've gotten this a few times, as well. A reboot seems to take care of it, but I'd like to get to the bottom of it.
    03-15-2012 10:49 AM
  4. jtanko78's Avatar
    I've tried a reboot. It does not help me at all. Every time I go to do an update or purchase an app, I get this stupid message. It's getting annoying. I was hoping for a fix in the latest update, but unfortunately not. I was thinking about doing a restore in iTunes but I will be more annoyed if I waste my time and it still does not fix. Has anyone tried this yet?
    03-15-2012 10:57 AM
  5. AgentHeracles's Avatar
    I have been getting this as well unable to purchase "Name of Item" and 25 other items. I don't get it every time but it does show up. The item is an ebook which is on a receipt that I have received but it still shows up. Reboot, install 5.1 nothing.
    Last edited by DJBox3r; 03-15-2012 at 12:36 PM.
    03-15-2012 12:31 PM
  6. robbietherobot's Avatar
    Does it happen on the iTunes on the PC/Mac too? Just buy it there and transfer?
    03-15-2012 02:45 PM
  7. Massie's Avatar
    Issue is that it happens for apps I bought a long time ago but no longer have installed. (And don't want installed.) I haven't found a solution.
    03-15-2012 05:07 PM
  8. Sigil's Avatar
    I have this issue too! Initially, this error only happend on my iPhone, but now it is happening on my iPad too. I find it annoying!
    03-16-2012 03:58 PM
  9. AgentHeracles's Avatar
    This is an update: I was in contact with Apple Support via email and sent them a screenshot of what the message said and they recently responded by saying it was fixed. I have still gotten this message several times this weekend when purchasing apps. The crutch of the matter, is that we don't know what's causing this to occur.
    03-19-2012 10:50 AM
  10. Korverfor3's Avatar
    To all having this problem... It's actually a very easy fix. I had it as well... VERY annoying.
    The solution (this worked on my ipad2, should work for every device):
    Go to the iTunes app on the device you are having a problem with... Scroll down to the very bottom where it says Apple ID - 'your apple ID' ... Touch that, it'll give you an option to 'log out' touch that... (for some reason, I had to do that twice... Whe you are logged out, do the same thing, but this time, 'log in' (I had to do that twice as well... Don't know why).... And then Bob's your Uncle! No more error message! You are all very welcome!
    03-21-2012 12:54 AM
  11. Wildo6882's Avatar
    I'm giving the sign out method the ole college try. I hope this works. If it does, a million thanks will be to you, brother.
    03-21-2012 08:51 PM
  12. Wildo6882's Avatar
    I'm giving the sign out method the ole college try. I hope this works. If it does, a million thanks will be to you, brother.
    That method definitely didn't work for me. I've signed out and back in a good 5+ times and haven't got the issue to go away yet.
    03-24-2012 05:23 PM
  13. Wildo6882's Avatar
    Anyone get this figured out at all? I'm still getting it almost every day. Kinda driving me nuts. It's the only major fault I've discovered with this phone.
    04-03-2012 03:59 PM
  14. Massie's Avatar
    Possible solution! The 5.1.1 update lists a bug fix as being for a problem with Unable to Purchase popups...not enough for me to update and lose my jb, but for stock users it's worth a shot. Let us know how it goes!
    05-08-2012 11:06 AM
  15. Peligro911's Avatar
    Found this fix


    1. Download iExplorer (formerly iPhone Explorer) on your Mac or PC for Free via http://www.macroplant.com/iexplorer

    2. Install and open iExplorer before you plug in your iPhone or iPad

    3. Plug in your iDevice and run iExplorer

    4. On the left expand Media and Downloads

    5. Scroll way down inside the Downloads folder to the only file ending in ‘sqlitedb’

    6. Rename that file to ‘sqllitedb.old’

    7. Close iExplorer and unplug your iDevice

    8. Close and reopen the app store and the problem should be solved (you need to hard close by double clicking the home button and holding the app store in the multitask menu then hitting the X)

    This causes the database to be re-created without the stuck entries that are causing the problem.

    We hold no responsibility if this causes any harm to your device but if you follow these instructions you should have no issues.

    Update 1: Or you can use DiskAid or other iPhone file system viewer.


    Sent Into Orbit from my iPhone 4S using Tapatalk
    Last edited by Peligro911; 05-08-2012 at 12:56 PM.
    05-08-2012 12:51 PM
LINK TO POST COPIED TO CLIPBOARD