1. tumnus's Avatar
    Hi all... looking for help (via jailbreak tweak or otherwise) for how to stop incoming emails from interrupting music playback. You know... music briefly fades for a second to indicate a new message has arrived. Haven't been able to find anything in my searches.

    Thanks,
    Tom
    01-17-2012 09:33 AM
  2. CH1N087's Avatar
    I think you could go into settings>notifications>mail and set your alerts to none, assuming you're on iOS 5. Just a quick fix if you can't find anything else.

    Hope this helps
    tumnus likes this.
    01-24-2012 02:48 PM
  3. colocolo's Avatar
    Xcellent question...It has never bothered me the fact that for a second or two the music gets faded out, but if that can be avoided, better yet.
    tumnus likes this.
    01-24-2012 02:53 PM
  4. tumnus's Avatar
    Thanks for the input. I know it's a small thing, but I do get lots of email, and it's annoying when I have it cranked in my car and the songs keep cutting out.

    Setting alerts to none would do the trick, but I would want it on otherwise. Turning it on/off is easy to do, but again, annoying.

    I was hoping there might be a setting I was missing, or even a jailbreak tweak.

    Thanks for your advice. If anyone else knows of anything, I'd love to hear it.
    01-24-2012 03:47 PM
  5. Jeremy's Avatar
    Thanks for the input. I know it's a small thing, but I do get lots of email, and it's annoying when I have it cranked in my car and the songs keep cutting out.

    Setting alerts to none would do the trick, but I would want it on otherwise. Turning it on/off is easy to do, but again, annoying.

    I was hoping there might be a setting I was missing, or even a jailbreak tweak.

    Thanks for your advice. If anyone else knows of anything, I'd love to hear it.
    Honestly I think you are out of luck. While I'm not big into the jailbreak scene any longer I do not believe there is a tweak to do what you are seeking.
    tumnus likes this.
    01-25-2012 01:18 PM
  6. tumnus's Avatar
    Ok -- thanks to all.
    01-25-2012 01:26 PM
  7. CH1N087's Avatar
    Thanks for the input. I know it's a small thing, but I do get lots of email, and it's annoying when I have it cranked in my car and the songs keep cutting out.

    Setting alerts to none would do the trick, but I would want it on otherwise. Turning it on/off is easy to do, but again, annoying.

    I was hoping there might be a setting I was missing, or even a jailbreak tweak.

    Thanks for your advice. If anyone else knows of anything, I'd love to hear it.
    Also, now that I think of it. Maybe something that might help a little bit is setting your mail to fetch manually and turn push off. Just a thought. Or setting your phone on vibrate. Just a few more suggestion, sorry if you've already tried them.
    01-25-2012 10:23 PM
  8. mvilla's Avatar
    Bugs me too. Especially if you're in the car, but I still don't like it with my earphones.

    To fix, just switch your phone to silent using the toggle above the volume buttons. This way you'll see the notification but won't hear the tone. If you have your 'vibrate while silent' mode activated you will still feel the vibrate.

    Hope this helps.
    Tartarus likes this.
    01-26-2012 05:20 PM
  9. asixs's Avatar
    This is 3 years late, but for anyone else searching for a fix, you can now put your phone into "do not disturb" mode (inside the settings menu) you can manually set it or choose a scheduled time. You can also easily active/deactivate it from the "swipe up menu" (control center)

    Hope this helps!
    tumnus likes this.
    08-04-2015 07:14 AM
  10. Tartarus's Avatar
    This is 3 years late, but for anyone else searching for a fix, you can now put your phone into "do not disturb" mode (inside the settings menu) you can manually set it or choose a scheduled time. You can also easily active/deactivate it from the "swipe up menu" (control center)

    Hope this helps!
    I still prefer the vibration toggle. Putting in DnD makes you miss some notifications.
    tumnus likes this.
    08-04-2015 07:40 AM
  11. Ariel Babalao's Avatar
    to prevent the music volume from lowering when an app notification is received, make sure to read the step-by-step guide below.

    Step 1: Launch Cydia.

    Step 2: Search for iFile and install it.

    Step 3: Once installed, tap on the iFile icon on the Home screen to open it.

    Step 4: Navigate to the following directory:

    System/Library/Frameworks/MediaToolbox.framework

    Step 5: Tap on SystemSoundLowersMusicVolume.plist and choose Property List Viewer.

    iFile Plist view
    Step 6: Scroll down to MailReceived and change its value from 0.1 to 1. The higher the value, the louder will be the music volume when an app notification. Note that this will effect Mails notifications only.

    ifile-plist
    Step 7: If youd like alter the volume level of other app notifications as well, you should change the value of UserAlert key in the same plist file.

    Step 8: Once done, reboot your device.

    The next time that you receive a Mail notification or notifications for apps, the music volume will be reduced to the value you just set in the plist file.

    It's really easy and just work.


    Sent from my iPhone using Tapatalk
    tumnus likes this.
    08-04-2015 11:41 AM
  12. Tartarus's Avatar
    Yeah, no thanks. I despise jailbreaking
    08-04-2015 11:43 AM
  13. Ariel Babalao's Avatar
    Yeah, no thanks. I despise jailbreaking
    Great. Provide despising it makes you feel good.


    Sent from my iPhone using Tapatalk
    08-04-2015 02:15 PM
  14. Tartarus's Avatar
    I mean jailbreaking my own devices. I can't speak for others
    08-04-2015 03:12 PM
LINK TO POST COPIED TO CLIPBOARD