1. shujaat's Avatar
    Hello all,


    This problem is discussed in many forums and in many threads in this forum. But I have a very different situation. I purchased a iphone 4 locked to AT&T. I unlocked it using gevey sim and then jailbreak it using jailbreakme.com. It was running 4.3.3 and BB 04.10.01.

    After all this I tried to call someone and found out that ear piece is not working. I searched it on different forums and some people suggested that a clean restore can fix this. So I updated my phone to 4.3.5. and to bypass the activation screen, i again jailbreak it using redsnow, though its tethered. unlock works perfect even better than 4.3.3, jailbreak, installous, cydia everything is working fine but still ear piece is not working.

    I checked it using voice memo, recorded some voice played it on speaker, I hear the voice but when I tap the speaker button to direct it to another speaker, nothing happens, i mean i cant hear anything.

    I checked ear phone port for any dirt, inserted and pulled out the ear phone's pin a few times, applied every proposed solution available on web but in vain.

    I have also read somewhere that ear piece stops working after jail breaking. Has any incident happened like this before? But I can't bypass activation screen without jail breaking.

    Any body please suggest something. Or Do i need to replace the ear peice?

    TIA
    09-08-2011 08:27 AM
  2. SeanHRCC's Avatar
    Did you buy it used? Did you check the water damage indicators before you bought the phone?
    09-08-2011 09:35 AM
  3. jeffrey1027's Avatar
    Do you still have warranty? If not water damaged, Apple will replace it
    09-08-2011 08:55 PM
  4. Corey's Avatar
    Does it work when the phone isn't jailbroken?
    09-08-2011 08:58 PM
  5. shujaat's Avatar
    Its not water damaged, I checked the indicators, these are white. Yeah I bought it used and unlocked using gevey sim. And for gevey sim to work we need jail break, so I couldn't check if ear piece was working when it wasn't jail broken. and now have updated to 4.3.5, and to bypass the activation screen, I need to jailbreak it.

    Anyway thanks for the suggestions, I am taking it the tech guys. They will check, whats the problem.

    I will update this thread when solved.
    09-09-2011 02:26 AM
LINK TO POST COPIED TO CLIPBOARD